Base - Rover and Emlid Ntrip caster

My company recently purchased 2 Rs2’s in hopes they would be an affordable alternative to a Trimble or Leica GPS unit. We mainly use our gps units to obtain elevations for site far from published benchmarks, we occasionally breakdown sections with our gps. I am having trouble getting the 2 RS2’s to communicate over Emlids Ntrip caster. Usually I’m getting no corrections from the base unit, i received corrections once for about 10 seconds but that’s all cooperation they had together. It also becomes increasing frustrating as phone continually loses contact with the receiver and it takes a while before it shows back up. Is there something I’m missing? These units where very much talked up by the dealer but it seems they’re no better than the GPS in my phone. I’d very much like to get these to work as we’d be in the market for 5 more if they can perform.


My setup is
2-RS2 receivers
Samsung S10 W/reach3 app ver7.5

In case you are creating a thread about an issue it is necessary to provide the following information to get help:

  1. Firmware image and ReachView 3 version.
  2. Detailed issue description. How does observed behavior differ from the expected one?
  3. Your step-by-step actions
1 Like

Lets solve one part of the connection at a time.

First lets troubleshoot base to caster connection.

How does the base connect to the internet?

1 Like

The plan is to have the base hooked up to the office WiFi and the receiver will be on the roof at a fixed point. The Rover is to operate using a Jet pack(mobile hotspot) or sim card (most likely sim cards) but we currently have a Jet pack for our leica setup so that’s what i’m currently using to try a test the equipment.

I’m having trouble putting them on different networks as the both want to revert back to the office wifi that my phone is usually connected to. I change the rover to the Jet pack network and do the same with my phone but after doing so my phone won’t find the receiver unless I go back to the office wifi and the receivers network is back at attached to the office wifi.

1 Like

Does the online status for the base show up solidly in Emlid caster?

1 Like

A post was split to a new topic: Trimble Base Emlid NTRIP Caster issues

Hi Chris,

This plan should definitely work! But I agree with @PotatoFarmer that we should start with checking the Internet connection.

Let’s start with the simple setup when both devices are connected to your office Wi-Fi. Are they shown online on the Emlid Caster page?

Does your Jet Pack transmit hotspot at 2.4 GHz? Reach can work with such networks only.

I’ve had them on the same internet connection, but its only shown “online” once for about ten seconds. Also yes the Jet pack is 2.4Ghz.

If you only have the base connected to Wifi, does caster report back online continuously?

From a computer connected to the same router what results do you get if you ping test the caster address, from command prompt.

Or on iphone

The caster does not report online when the base is connected to the wifi.

Ok so its possible to reach caster, and you have a good ping.

So if it does not show up online, possibly the configuration or password does not match.

Or your router may have port 2101 blocked. Will show up in caster if using a phone hotspot for internet?

Could we get a pic of the reach base tab setup for reaching caster? you can omit any sensitive information.

1 Like

I will try and get everything set up this afternoon and document my process

Hi Chris,

Do you have a possibility to connect your base to another network? Just to test. I remember you had issues with the Jet Pack, but maybe your phone hotspot? Now, it looks like a network issue to me, but I want to ensure to continue troubleshooting in the right direction.

1 Like

I have some trouble sometimes connecting to Reach with my Android phone even though they are on the same network. That is mostly when mobile data is enabled. Disabling mobile data makes WiFi communication possible, but I’ve increasingly been using Bluetooth connection between my phone and receivers.

Also, Android has the infuriating behavior of changing for any known WiFi network which has access to internet. This means the Reach hotspots and consistently rejected by my phone if I’m near my home or workplace networks.

The easy solution is to have SIMs in the receivers as their hotspots are then just as good as any other network and shouldn’t be switched by Android.

Still no corrections

I dont have any problem connecting to my phone, ive tried tethering the Bluetooth but that doesn’t work for me.

Reach-001 is my base 002 is my rover

Unfortunately we need these to work before we invest into Sim cards and more receivers. I have no idea why these aren’t working together, I guess i’ll try a 3rd party caster and see if I can get that to work.

You guys are really beating me into submission. I tried another test and absolutely failed. From what i can tell there’s no other way to connect to these receivers other than via wifi, even though my bluetooth is paired and on, makes no difference. I can only connect to my rover via the internal hotspots or if it’s connected to the office wifi and even then its spotty. If i switch the receiver to my mobile hotspot there’s no way to connect to the receiver. I am back from my test and now I can’t find my base connection…

I have used GPS systems for 24 years, never have I had so many connection problems. You need a stand alone data collector that will communicate with your receivers, trying have people use phone apps is a terrible idea given phone software changes daily. A stand alone data collector would give you more control, more seemless connections and be rid of this WiFi abomination that just doesn’t work.

I’m begging for some help here before these receivers turn into expensive paper weights which is the only thing they been good at so far.

There have been issues with connectivity that were firmware related in a couple updates though so it’s not impossible that you’re getting this. What firmware version is on the units right now? Also if you can generate a system report from the units and link it here, it might speed the troubleshooting up when an Emlid rep sees it (unless you’re already in contact through other means like e-mail).

1 Like