Base and Rover not communicating and remains "Single"

Hello friends!!!

My base and rover doesn’t communicate and I really have no idea why.
This is my rover settings, config and satellite details:

And this is my base config and settings details:

As @igor.vereninov said “make sure that corrections are getting through

I tried for long time but seems no connections with base, therefore, not gettings any grey bars. Please help me where I am doing wrong.

Also, I put GPS_1Hz but still my green bars are coming and going.

My both Reach receivers are on the top of the car and I am in parking area outside with beautiful sunny day.

Any help would be highly appreciated.

Regards

Hi!

Both units are on the same network? Are you sure that base IP address is 192.168.1.45?

Yes, it is.

Base IP address is 192.168.1.45

And yeah!! Base is configured on MacBook and Rover is configured on Windows 10 Laptop.

Hi!

I think some more information. Is the base started? Can you connect to 192.168.1.45:9000 with another program? Something like telnet.

Yes it started.

Also, I did
$ telnet 192.168.1.45 9000
Trying 192.168.1.45…
telnet: connect to address 192.168.1.45: Operation timed out
telnet: Unable to connect to remote host

Any suggestions?

You either have multiple networks, or a network issue that doesn’t allow them to communicate. You mentioned something about base config on mac and rover conf on win laptop which isn’t making much sense.

For now you should go back to the basics, hell even indoors just till you get something. A test that something isn’t working is the failed telnet. Your mac should be able to telnet both devices at least on port 22 (SSH). At least during troubleshooting phase, I wouldn’t count on the DNS, reachrover.local, things are working. Find a way to discover the devices via IP and just use IP addresses for now.

A similar setup I have to get started is this:

  1. Using a wifi hotspot, cell or dedicated device, or a basically empty wifi network configure one laptop and both reach devices to the network
  2. Discover all three devices mac and IP, this can be done using a program like nmap or just looking up the access point logs of DHCP server. Both of the reach should set an appropriate host name.
  3. Make sure you can at least hit port 22 on each of those devices. Also ping should work iirc.

Once you have verified that is working then start the working on getting RTK fix. If you are still having issues with the two units talking to each but can talk to one of them via the laptop, SSH into one and then perform network tests from there be ping or telnet (https://docs.emlid.com/reach/software-development/#connecting-to-reach-via-ssh).

3 Likes

Thanks @mr337 for your reply. I tried the basis things and configured both Base and Rover on MacBook.

This is the network details how I am connecting both (Edison3 and Edison 4):

Now I tried http://reachbase.local (Base) and http://reachrover.local (Rover).

Still same results. Only single and no grey bars. SEEMS BASE IS NOT COMMUNICATING WITH ROVER. I have really no idea whats going on. I am clueless.

@egor.fedorov I tried telnet but it says:

$ telnet 192.168.1.45 9000
Trying 192.168.1.45…
telnet: connect to address 192.168.1.45: Operation timed out
telnet: Unable to connect to remote host

My signals keeps fluctuating even after using GPS_1Hz
Please help me.

Regards

I am trying to ssh reachrover but its going to reachbase.

My-MacBook-Pro-2: $ ssh reach@reachrover.local
reach@reachrover.local’s password:
reachbase:~$ ls
GPIO_Py MPUtest RTKLIB ReachView Ubloxtest
reachbase:~$

But when I am doing ssh reachbase then following error is coming:

My-MacBook-Pro-2: $ ssh reach@reachbase.local
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: POSSIBLE DNS SPOOFING DETECTED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
The ECDSA host key for reachbase.local has changed,
and the key for the corresponding IP address 192.168.2.15
is unchanged. This could either mean that
DNS SPOOFING is happening or the IP address for the host
and its host key have changed at the same time.
Offending key for IP in /Users//.ssh/known_hosts:9
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ECDSA key sent by the remote host is
SHA256:
Please contact your system administrator.
Add correct host key in /Users//.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /Users//.ssh/known_hosts:5
ECDSA host key for reachbase.local has changed and you have requested strict checking.
Host key verification failed.
MY-MacBook-Pro-2: $

Ok for this, i did

My-MacBook-Pro-2: $ ssh-keygen -R reachbase.local

But the problem remains same:

Even if I’m ssh to either reachbase or reach rover, i am always going to reachbase server. Why so?

Regards

Ok. This has something to do with you configuring USB-Ethernet access to Reach. It might interfere with the way calls to a certain IP are routed. Try doing the same thing, but with the units connected to a different power source, like a phone charger.

1 Like

Hi @egor.fedorov

What do you mean by this?

If I connect both units with phone charger, then how I am going to access ReachView App? Can you explain me more briefly or step-by-step if possible.

Sorry for any inconvenience.

Regards

A post was split to a new topic: Obtaining base coordinates

Ok, the Ethernet-over-USB is more of an additional feature, we do not recommend accessing the app like this. The primary way to work with ReachView is Wi-Fi connection. The workflow is described in the docs.

1 Like

Hi @egor.fedorov

Sorry for late response. Was busy with other office work. So now I am trying to do the primary way to work with ReachView, i.e., Wi-Fi connection.

I am working on MacBook,

Step1: I re-flashed my Reach device
Step2: From my Network list, I selected "reach:14:20 " and put password "emlidreach"
Step3: I go to http://reach.local:5000 and in Edison setup, I put

  • New Device Name: reachbase

  • Network name: My router SSID

  • Password: (SSID password - after selecting WPA-2 Personal something)

Step4: Now it went to leaving setup page and automatically connect to my Wi-Fi network (i.e., my router SSID network)
Step5: Now when i go to Safari browser and go to URL http://reachbase.local, it says “Safari Can’t Connect to the Server - Safari can’t open the page ‘reachbase.local’ because Safari can’t connect to the server ‘reachbase.local’.”

Step6: I am checking “Fing” app on my iPhone and there is no IP address pointing towards “Reach device” or "Murata Manufacturing"
I am not sure what step am I missing? @igor.vereninov @bide

Please help me out.

Regards

If you can’t see Reach with Fing, then maybe it couldn’t connect to your wireless router and so it has created it’s own wireless hotspot again as “reach:14:20”? Can you check that?

Thanks @bide for your reply.

No there is no Network Name called “reach:14:20”. I checked.
I even tried http://reach.local/ and http://reach.local:5000 but none of the pages are loading. And I am connected to the internet through my Wi-Fi.

Also, I am leaving setup once I setup reach device

Well, there are 2 things I would do from here:

  • log in to the wireless router’s admin page and go to a status page and see if you can see reach’s IP there (maybe listed by mac address ending in :14:20)
  • the other thing you could do, if you are familiar with the command line, is to plug reach into your computer and use the ethernet over USB connection. SSH into reach as root and run ifconfig to see what IP address has been assigned to wlan0.

Once you know the IP address assigned to Reach by your wireless router, then enter that IP address into your web browser instead of reach.local or reachbase.local

If Reach is not getting an IP address, then you must have wireless connection problems which could also be troubleshot through the ethernet over USB connection. For example, by running the configure_edison --wifi command

1 Like

Thanks @bide

It worked.

The problem was with my router. I changed the router and it worked. I am currently getting float.

Once again thank you to @bide @igor.vereninov @mr337 @egor.fedorov

Regards

2 Likes