Base and rover connection with radios does not work

dear all,

I have 2 reach, Base and rover connection over wifi work fine. Now i need to go the next step and connect them over a 3dr modem.

I have 2 modems: one serial version and one usb version. They came in that configuration.

I connection the usb modem to the base and connect the serial version to the rover (so i have still a usb at the rover)

Problem 1: The rover status screen shows no connection:

do I have to “pair” the 3dr modems?
I set 57600 bound at the reach. But is this the speed of the modem? Do I have to change the speed of the modem?
What should I do or try next?

Problem 2:
The base is not accessable in wifi if the usb modem is connected turing the boot.

is the booting problem known? what should I do?

with best regards


Could you check if the radios work by connecting them to your computer and opening the COM/serial ports?
In general, settings the same baud rate on both sides should be enough.

What do you mean by rover showing no connection? The configuration seems fine.

Could you be more elaborate on the USB issue? How do you connect the USB radio to the base Reach?

Also, it’s a good idea to check whether you have TX and RX wires mixed up. It’s a common mistake when working with UART.

My experience is with the RFD900 radios, not the 3dr, but I believe they use the same commands, so I will answer as if they are RFD900 units.

  • with SiK software version 1, NO
  • with SiK software version 2, YES (not paired, but one set as master and the other as slave)

In addition, the NETID (network ID) must be the same number on both units

There are 2 speeds which are set independently:

  • serial for communication between Reach and radio (usually 57600)
  • air data rate for communication between radios (I’m using 32kbps right now)

Yes, you should check the serial speeds are the same as Reach (57600) and if you plug the radios to your computer for testing, make sure your computer’s USB/serial port settings are set to the same speed.

I’m not sure if this is the same problem you are having, but I can’t boot Reach with the radio plugged in. So my workaround for that is to disconnect the radio power, then boot Reach, then reconnect the radio power. After that it works fine.

Another thing I did was read the RFD900 documentation and get familiar with the modem AT commands. Then I hooked both modems to my computer and made them communicate and pass keystrokes back and forth. Then I connected them to Reach and tested with keystrokes. What I mean is typing in one radio and watching the characters appear from the other one. When you prove to yourself that the radios are working then start up ReachView and everything should be OK.

Dear @egor.fedorov and @bide!

I made progress!

radio is connected to usb (115kboud). If I start the base than the red led is blinking on the modem connected via usb to the base AND the red LED on the other radio is also blinking!!!

so there is a connection between base and radio and there is a connection between the 2 radios!
So it must be a rx tx swap problem. I will check this now.

thank you and best regards

Dear @egor.fedorov

thats strange!
it seams that the data from the base gets over the air to the rover modem (booth red leds are blinking) but the data does not reach the rover.

I have swapped rx and tx and tried booth. no success…

whats next?

best regards

hi @egor.fedorov

here is a fot of my test setup of the rover:

here is my config screen of the rover:


That’s good that you can see the red LEDs blinking.

If your serial or USB speeds are set incorrectly, the red LEDs can still blink. The data that is being sent will be corrupt and the rover will not be able to use it. So please confirm that your 3dr radio serial speed matches your speed in ReachView.


I think I have exactly the same issue. As far as I can see I can’t see any problem/error with my setup, but the reach units don’t communicate via radio.

The first radio LED are both solid green. The second red LED seems to show the transition of data…

Any hints?

try to switch to bautrate 57600
at every unit


I have solved the problem!

Problem: i do not know how to set the baute rate, there is no info if it is correct or not, it is a try and error thing… and you have to us an external sw to change the bautrate…

Solution: i bought another set of 3dr v2 radios with a usb at each unit!
It works straight out of the box.

I insist that emlid changes the docu so that the 3dr v2 is the favorit solution.


@Andreas_Ortner thx for the hint again, though I read it aleady seravle time I didn’t try it until now.

Problem solved!

That was exactly the problem, as well I had to set the bautrate to 57600 on both units as I had to switch the TX and RX wires, though I had connected them before as described in the docu.

@Franz_Helmli I was about to buy another radio system, but I’m happy know that it works with this “cheap” units.

1 Like


I have used many 3dr v2 radios and I know they can work quite well.

After a few days of use they often fail. The radios are very cheap and are very sensitive to damage from not having an antenna connected.

The much more expensive RFD 900mz radio work much more consistently and have longer range. The RFD 900mz radios have the same type of firmware that the 3dr radios have so changing settings uses the same application.


I don’t get the USB option under serial in he base station. I only get UART odd.

I have the same issue, i can only see UART. I am running the latest version of reachView (0.4.6). Is USB a feature that has been removed? I am running MAC OSX, but also have Windows on Parallels.

@Multirotorcraft, I still only see UART, but found another way to do this:
It seems that intel Edison creates a virtual Ethernet port through USB, and you can use this to obtain the corrections. Follow the instructions in the link above and make sure that:

  1. Base is configured as tcpsvr using port 9000.
  2. The GPS injection in Mission Planner connects to the TCP server of the local address of this virtual Ethernet port.

For me it worked great.

There’s an issue with radios over USB. We are working on it.