Powering 3dr Radio via USB port

I can’t power my 3dr radio using the USB port
I’m powering my reach via the DF13 port, using a Lipo battery, the reach powers up just fine, but when I connect the 3dr radio viaUSB port it dosen’t power up. The radio is working fine, I have tried powering it up with my computer and it works.

I’m using reach image 2.3 and reachview app v2.1.3

this is the setup I’m working with

Hello Luccatiel,

I have the same issue connecting the radios via USB and the radios led did not turn on. I tried connecting the radios to my laptop and they work fine. I have changed the radios and the problem persist.

A related problem with radio communication was posted last year here> Base and rover connection with radios does not work
and here> Reach can't find 3DR radio connected via USB OTG

In that post, there was a problem that apparently has been solved in the latest version. But I can not tell since I haven’ t tried it yet.

One possible solution is changing the radio to the DF13 ports as shown in this video posted by Dennis Baldwin> https://www.youtube.com/watch?v=YqljIDxuGWY

Let us know how it goes.

@luccatiel if you want to connect USB device to Reach then you should plug the OTG cable in the microUSB port on Reach, not on 3DR radio (OTG cable is the short one). That’s the only way Reach would detect the OTG mode correctly and provide the power.


Hello Mikhail!
Thank youl for the help, I switch the cables as you suggested and now it works fine. I get base corrections transmission.

Thanks a lot!

This topic was automatically closed after 100 days. New replies are no longer allowed.