Auxiliary PWM channels for Navio 2

Hello guys,

We wanted to let you know that as of now Navio 2 supports setting the different frequency on channels 9-14 and 1-8.

This lets us use any kind of gimbals on channels 9-14 and fixes problems that some of users had been facing.

We strongly suggest upgrading, i.e.

sudo apt-get update && sudo apt-get upgrade

This should fix the problems with PWM frequency on channels from 9 -14.

Auxiliary function switches on channels 5-8 are still not supported and could lead to erroneous PWM generation on motors’ channels and that’s why we do ask to NOT SET AUXILIARY FUNCTION SWITCHES TO RC5…8.

This will be fixed in a little while. Either way, we think that wouldn’t be a problem, because the only thing you need to do is plug in the gimbal to another channel on the servorail.


So is it now okay to run sudo apt-get update && sudo apt-get upgrade on the latest RTOS?

I thought you guys were encouraging people not to do that.


People do it anyway, so we’ve decided not to fight it and make it more difficult to break things. :slight_smile:
In the latest image it is even ok to run apt-get dist-upgrade.

Has anyone been able to get a servo gimbal working using this latest update? I am still having problems- servo gets power, but no movement as a result of FC roll or pitch after setup in Mission planner. It’s hard to say if this is a software or hardware problem at this stage because its a new setup for me.

Next step will be for me to watch the RC outs to see if the FC is trying to do anything.

@Bradley_Scott we’ve testet gimbal on channels 10 and 11 and it worked fine.
Could you please provide more details? gimbal model, what you’re doing step-by-step etc.

Sure, I have this gimbal frame:
Powered by two servos of this type:

My Mission planner settings are shown here:

And my servos are connected like so:
Google Photos

I have rebooted my Navio to make sure that my settings have remained the same after a reboot, and that doesn’t seem to be a problem. As soon as I enable tilt or roll stabilise on RC10 or RC11 t I seem to be get the erratic motor and gimbal movement described on other threads.

I’ll try another apt-get update and upgrade and see if that improves anything

Apt-get upgrades sorted it. Must have had the older version with the erratic gimbal problem still installed.
My roll response is sluggish but I suspect thats got to do with my servo rather than anything else

Great to hear that it’s working now.