Autel and Local NTRIP Caster feature

I have an Autel enterprise RTK. I tried the new function fro local NTRIP and unfortunately it gives me an error as per the attached screen shot, do you have any other suggestions on setting some other parameters?

Same happens to me with an EVO II Pro RTK with standard controller, I believe is not an RS2 problem, because when connecting with the Lefebure NTRIP Client app, I can receive corrections.

I also have an Enterprise EVO RTK that has the same issue. Works great with my Phantom 4 RTK. Its an issue with the port number being used. If we could change the port number there would not be a problem working with Autel RTK.


Is Autel Explorer looking for a limited range of port #s?

If so, the Emlid team is the only hope because Autel tech support at this level is probably not happening.

I know different networks have their own configurations, but port 9090 seems like an odd one for them to use from a traditional IT standpoint. When I have used 9090 in the past, it is always been for some type of specific application like a server or security software. Our NTRIP ports are in the 2000 range.


Confermo che anche i con autel evo 2 rtk ho lo stesso problema. Confidiamo in Emlid.
I confirm that i also have the same problem with autel evo 2 rtk. We trust in Emlid

I’m sure Autel has a forum. Let’s spam it with NTRIP requests! That’s really the only thing that’s keeping us from replacing our Phantoms.


But I don’t know what exactly to ask, could you suggest me? What should the 9090 port implement or what?

Take a look at this thread. This post in particular seems to describe exactly the experience. I am sure Autel knows about this.

Autel has mostly fixed the problems with connecting to NTRIP. I know of a guy that uses Emlid Caster with an Evo2 RTK all the time. It is this new Local NTRIP that is not working.

Autel does not have a forum. They have a couple of Facebook groups that are moderated by a couple of good guys that work for Autel and will pass on feedback from users, but they have no control over anything. Autel’s software backend crew is extremely thin and basically is just trying to put out fires. That is why I commented that Autel Evo owners will need Emlid to allow a port setting that Autel Explorer will accept. If that is in fact the hang up. Assuming @Dirk somehow knows that is the case.

1 Like

Good morning,

Actually there is another competitor who managed to connect Autel evo in ntrip, I have a link but I don’t know if I’m allowed to post it, being a competitor of Emlid, so I ask before being authorized to post it.

Without naming names……Go to the controller, RTK setting, RTK Service Type choose Custom network RTK, NTRIP host, port the same as Inno 7’ setting (default 6666), user admin, pwd admin, Mountpoint the same as Inno7’s settings( default ).

If you also want the pictures, let me know

Hola @arch.antoniopalma
Me podrĂ­as enviar las fotografĂ­as por privado?


I am addressing Emlid moderators, is there any hope for us Autel operators that the LOCAL NTRIP connection issue will be solved?

Thank you

Hi guys,

Hmm, unexpected issues with Autel :thinking:

That sounds interesting. If that’s the case, we could assign the Local NTRIP port in the 2000 range.

If someone can confirm that Autel works fine with 2000-2999 ports, please let us know! For example, our free caster uses 2101 port.

@usicilia, @david.negrete, @Dirk, @arch.antoniopalma, have you guys ever worked with our caster and your drones? Does it work?


Awesome. I think it’s at least worth a try. They may have their ports limited. It might be worth a support ticket with them to verify what they are accepting.

1 Like

Hello Svetlana,
I confirm that with emlid caster is therefore with port 2101 autel and emlid work.


One of my locally available NTRIP providers uses Port 21XX and the Evo2 Enterprise (v.2) works fine. I have not used Emlid Caster.


I have not used it, but I know of someone that successfully uses Emlid Caster all the time with an Evo 2 RTK (v.1).