ArduRover crashes within some seconds after unsuccessful compass calibration

emlid-raspian-2016-04-08, completly new
ArduPilot Upgrade
ArduRover (3.0.0)


I did no changes and started the compass calibration like mentioned with the newer “onboard Mag Calibration” routine. It did not work, error message something like “missing input”. Same behavior like with a Pixhawk and ArduRover 3.1 and 3.1.1 by the way (Mission Planner). So I tried the conventional way with “Live calibration”. This was also not working. So I tried to switch some settings - all refused! It was not possiblle to change any kind of options. After a second the refusing message occured. So I did a reboot. Big mistake!!! :joy: After this reboot, ArduRover is crashing now after a few seconds. All other kind of vehicles like ArduCopter-x are running fully normal.

I think the reboot caused a damage or missconfiguration of a settings file for the ArduRover compass or something like that. Where are the settings stored, file names?
Is it possible to “repair” the settings or will a kind of new base config generated automatically if one or some decidedly files are deleted?

Hope that somebody can help.

Regards, Thomas

All ArduPilot related stuff is stored at /var/APM. If you remove /var/APM/ArduRover.stg you should be back on track. Have you sudo apt-get update && sudo apt-get upgrade? Even though, it’s not strictly linked with the issue at hand, I kind of should suggest it.

So you’re saying this is not Navio 2 specific?

If you’re comfortable compiling from sources or downloading, I would give a try these other versions.


thanks, ArduRover is running again after deleting APMrover2.stg. Upgrade is not working again, but I ihink I did it before. If try to run the upgrade again, I get apm-navio2 is already the newest Version. But it is not possible to calibrate the compass. By the way I see only one (compass 1). Further more the Mag calibration stops at 99%. Live calibration sometimes with success but Offsets like 369,722,271. We did now compass calibrations for hours and realized that sometimes after a try with Mag calibration the direction is wrong from 90 to 180 degrees. Missing 2nd compass and so on, is it possible that we have a defective board?


I was able to reproduce your problem. As it turned out, even though 3.0.1 was a minor release for other boards, Navio 2 was affected drastically. For the time being you can download the latest stable from here.

  1. wget
  2. chmod +x APMrover2.elf
  3. Remove old params and launch
  4. Perform onboard calibration (this does work now on both compasses!)

Thanks a lot for reporting. I’ll try to upload the newer debian package with the proper version by the end of this week.


Thanks! It seems that it work.