App keeps freezing

Hi all

I updated my app now I can’t survey any more , when I go to the blue measure a point button everything freezes and the app totally crashes . Was fine before update ? Coord system osgb1936 and Odn heights ? Any help appreciated

Thanks

UPD. The comment was edited

I’ve removed my previous comment not to confuse anyone as it contained misleading info. Please check my post below: App keeps freezing

Hi thanks for your reply
This is far from ideal ? This is totally ridiculous
So can I still stake out and import jobs etc …. If I want to type in a coordinate and stake out how can I do this also ?? Do I have to convert to cs.global and type in ???
I have jobs waiting to set out week

Nothing will change in your workflow if your base is set up in OSGB1936. Global CS will output coordinates in OSGB1936 as well.

You can just test that and let me know if some questions arise. I’ll help you out.

Thank you , I shall try and work around . I have tried to add a vertical datum when selecting global cs in the new project file ? Do I need the receiver connected to do this as at present the option is blanked out . Thanks


Hi I tried as you said using global cs and this is the csv export I got back , it has no local cords and won’t let me input a new vertical data set . Can you please help , this is the second day of lost time .
Stu

Stuart,

To choose vertical datum, you need to work with a projection. Please try EPSG:7405. In that case, Easting and Northing columns stand for British National Grid coordinates, while Latitude and Longitude for OSGB1936.

Longitude and Latitude columns are local cords in that case. They are OSGB1936.

We made these changes in the app because we couldn’t support some new features without them.

I see it’s not very suitable for you, and I’d like to discuss it with the team. But firstly, I want to understand some details about your project requirements. Why do you work with the geographic coordinate system, not the British National grid?

I’m asking that because we need to understand how to make it the best way.

Hi . Thanks again for getting back
Osgb36 is xyz in meters is national grid to the surveys I have to work to
Also our datum is odn newlyn
Here is a previous survey showing what I mean . This is from previous emlid surveys

Hi Svetlana
If you could please tell me how to set this up that would be great as it looks like I’m going to lose another day because of this update . When I choose global cs I cannot choose a vertical datum . When I record a point in the app it only record as lat long . I cannot use this for my environment agency projects . They need to be uploaded in Osgb36 to my software via csv …… if you have the settings that would be great
Stu

That is a very helpful thread. It appears i have the exact same problem with you, but instead of your OSGB36, i used to work without any problem with the local projected GGRS87/HEPOS, with ntrip corrections (provider) in Greece. Now i use the Global CS, and i can no longer get the projected coords and the orthometrical height as output. Hope there is a fix soon, i think the global cs backfired. Till then, i have downgraded to 6.11 and i continue to work fine (though this version had an update rate issue), i think this might help you.

Hi thank you , I still have major issues and no help at minute . Am I please ask how I can back date the app update ?

I just googled for the apk of reachview3 in version 6.11 and found it. You’ll have to uninstall the app with the 6.12 version though and deny the app’s notifications for update to newer version. Be careful from what apk site you download it from though. For me, it was the only way to work.

Hello everyone,

Am I understanding correctly, that the main problem is inability to combine Global CS with an orthometric height? In both cases, there’s no need to do that. You should use corresponding projected systems like GGRS87 / HEPOS or OSGB 36 / British National grid. They both can be combined with geoids. And LLH coordinates are available, if you need them.

Global CS option is limited in functionality by design and should not be used for real work. It’s really something to get to know your way around the app.

Regarding the freezes, is that still an issue for you? We can confirm that it’s a problem for Blackview phones. Unfortunately, the fix for those likely won’t be available until late January.

It would be really helpful if you could share exact systems you use (project info screenshots or codes) and your phone models.

2 Likes

Hi Egor
I have a samsung tab active 1 and 2
When the global cs option was chosen the option to apply a correction height was not able to select , the button was not available, the measurement could read in global cs and rtk get a fix and re order (onlybin global) when I selected osgb36 and applied a odn height with correction the app froze and crashed with the blue cross measure button.
I have reverted to version 6.11 and all works fine again
Thanks
Stu

There are several OSGB systems we have in the app. Would you mind sharing the EPSG code of the problematic one? Is it 27700?

While using GGRS87/HEPOS with greek geoid height, just after pressing the (+) button, the app crashed, just like in Stuart’s issue, and i supposed my local CS got discontinued too. I have tested it in two xiaomi phones (a redmi note 9T and a redmi note 6 pro), with same negative results.

Edit: After what you stated, I’m kinda unsure if the crashing occurs because of some unknown bug, or because my local CS is no longer supported in 6.12.

Me too had issues with app crashing while pressing the (+) button. This was happening with GGRS87/HEPOS plus greek geoid in an older version of RV3.
Luckily for me I don’t use RV3 for data collection. I use my M2 only for ntrip base station.

To be honest, i remember crashing with the same way while using the GGRS87/HEPOS months ago, but it only happened like 2-3 times, and after a reboot in my phone, it worked fine. But after 6.12 the crashing insists, and there was no way for me to fix it.

Edit: I use the RS2 receiver.

I am having this same problem. My coordinate system is WGS 84/UTM zone 16N + NAVD88 (GEOID 12B) height. Please help! I am not sure what to do because we now have lost two days in the field trying to figure out the issue. We also use metrics. According to the update we should not be having problems but we do.