After update

Hi, just now i tried update rechview. But i don’t know why i can’t open reachview after that.


Any one can help me to solve this.

The led just green without blinking.

Thank you

Tell us the LED blink sequence that you are seeing on your Reach. I see now, solid green.

The quickest way is to set up ethernet over USB and ssh into Reach at 192.168.2.15 and run ifconfig

Usually it doesn’t stay on steady green for very long. I assume you have waited for a while and then rebooted it?

I have waiting for long time, still green, then i unplug the power, and plug again, i’m waiting, then green again without blinking…
I have no experience in ssh, would you explain to me the detail should i di with “ssh”.

I try to open 192.168.2.15 in chrome. But no result. The site can’t be reached.

I look at advance ip scanner, there is a tools called ssh. I clicked it, then show cmd.exe like this picture

Someone else may have a better suggestion for you on why the solid green LED.

However, If you want to try ssh, then you should search the internet for a how-to. I will give the basics, but without previous experience this will be hard:

First, you must get ethernet over USB working. See the docs: https://docs.emlid.com/reach/software-development/#connecting-to-reach-via-ssh

Once that is working, then:

  • download putty.exe at: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html
  • run it from your Windows command window (terminal window) by typing putty.exe - do not double-click it as it won’t work that way oops, I was thinking of a different program, pscp.exe - anyway, yes double-click on putty.exe
  • use the address 192.168.2.15
  • once you have logged in, then you are in a Linux environment on the Edison processor
  • at the prompt, type ifconfig and read the IP address which is beside the name “wlan0”
  • that is the address that you can connect to Reach on over your wireless network

Yes, that is the command window from where you will run putty.exe (as long as it is saved in the same folder C:\Program Files\Advanced IP Scanner ) see correction above

wait a minute, did you try the address in your screenshot above that says Murata Manufacturing?
http://192.168.43.211

Yes, it is.

I have try with PuTTY, after setup RNDIS. But i get this picture


And

My reach is still connected to my wifi.

OK, you are fast. Have you rebooted Reach since changing the RNDIS settings? Try that. But first, go back to your advanced IP scanner and try those IP addresses in your browser.

Just now i rebooted reach and deactived my wifi. Then try to login puty, i still can’t login. Should i write port number?
Before i try access my reach with that ip address, but can’t be openned.

I’m sorry, but I don’t have Windows operating system, so I can’t help you any further with RNDIS, except to say to go back and make sure you followed the steps correctly in the docs. If you haven’t set your computer’s network to 192.168.2.2, then you won’t be able to access Reach at 192.168.2.15

may be i should reset my wifi in reach. but i don’t know.
i still try with putty. should i fill port number?
my reach is connected in my wifi now.

port number is 22 by default, no need to fill it in.

yes, I would reset the wifi in Reach if you can.

i can open reachview app now with RNDIS. and i’m login (192.168.2.15) with putty.
so what should i do next.

after i open with browser, i found reboot button, then i pusshed, closed application, then enter again, the site can’t be reached… i don’t know what’s wrong…
i can only open 192.168.2.15:5000 (device information), the information is ip address 192.168.0.105, but i can’t open it.

get it back working with RNDIS and login with putty and do what I said earlier:[quote=“bide, post:7, topic:3071”]

  • at the prompt, type ifconfig and read the IP address which is beside the name “wlan0”
  • that is the address that you can connect to Reach on over your wireless network
    [/quote]

ip address is 192.168.0.105

i use that ip address in chrome, but i still can’t open my reachview