A few things

Ok, I have some more questions.

I am having no luck calibrating my ESC’s. I followed videos that I found here in the forums to no avail. What are some common mistakes?

ALSO, This may be an answer to my first question.

I have the Taranis x9d plus, I notice when I go to calibrate my receiver in Mission Planner, it has my controls all screwed up. For instance, when I move the throttle, it moves my Roll and as far as I can see, none of them are correct. Why would this be? So far, I feel like the only thing I have done right is bind my receiver to my transmitter and connected to Mission Planner.

I could really use someone taking me under their wing and guiding me here.

I would greatly appreciate it more than you can imagine!


I had the same issue… Have a look at:


and adjust in the Taranis from the menu to match what is expected by ArduCopter.

Nice that helped so much! Now, how do i calibrate my ESC’s? I am not getting my motors to respond at all, and i would assume that is due to the ESC calibration. Thanks in advance!


Ok I have successfully calibrated my ESC’s, however after I restart my APM, i can’t get them to arm!


Man I am getting SO CLOSE! After this long day and almost wanting to toss this thing!

Any help most certainly appreciated!

Depending on your version of arducopter, I used mavproxy to set the ESC calibration flag, and restarted arducopter which will put the ESCs in calibration mode. There are other ways to do this, I believe the standard arducopter procedure will work, but the method I used works for both joystick and rc controller.

Arducopter has prearm checks enabled. If you did not complete the whole setup and calibration process, Arducopter will not let you arm the motors.
Have you sorted out your RC channel problem?
You should concentrate on one issue att a time.

Hey thanks for the reply! Yeah I did sort out the other problems. The only issue I seem to be having is GPS errors. When I try to arm it says PreArm: GPS horiz error.

I have googled that, to see what info I could find but I am not really find a straight answer for a resolution.

Ok so I found that I had geo fencing on and that was messing me up. I disabled that and I was able to arm the esc’s, NOW i have another problem, it says PreArm: Check Board Voltage

I have no idea why its doing this. nothing is shorted, and my batteries are fully charged as far as I know (both are showing over 15 volts). So what could be causing this?

From the code, the Board Voltage is expected to be between 4.3V to 5.8V, it is not the battery voltage. I am not sure if Navio+ measures the board voltage, I have disabled this check on my setup, maybe someone from Emlid can confirm.

The reason i mentioned the battery is because it powers the navio+ and if its voltage was to low, then perhaps it would be lower than it should be. Anyways, I am at a total loss. I have no idea why its doing this. I can recalibrate the ESC’s and the motors spin up fast! So i am just confused and hoping there is no dmg being done to my board.

Please read my reply again, board voltage is not battery voltage. It is the regulated 5V from the battery, I have measured my board voltage and it is fine (the PI would not boot up otherwise anyway). So, it is either the Navio+ does not measure board voltage, or there is something wrong with the Navio+ board. I have this problem too, so lets wait for someone from Emlid to comment.

OK, I just checked the code, and it looks like Navio+ does not have board voltage:

/* Board voltage is not available */
float board_voltage(void) 
    return 0.0f; 

So, to get around this, please disable the prearm check for board voltage.

Yeah that makes sense. I should have thought about the board having a part of the circuit that regulates the 5v. Good call on waiting for some feedback!

i have looked over APM Planner V2.0.18 many times. I still have not found a place to disable the prearm check for board voltage. I am getting the status Text: "PreArm: Check Board Voltage"
I have the Navio+ and RaspberryPI 2

@KeithC: You mentioned Navio+. Which Raspberry and Which APM Planner are you using?

Any helps as to where to look for this Disable “PreArm: Check Board Voltage” parameter?

Go to the config/tuning tab at the top, then click full parameter list on the left. Look for Arming Check.

Valid values are 0=disable, 1=enable, -3=skip baro, -5=skip compass, -9=skip gps, -17=skip ins, -33=skip sonar, -65=skip RC, 127=skip voltage -> see below


1 Like

This is great news.
I entered the 127, skip voltage and the APM Planner quit yacking at me about the “PreArm: Check Board Voltage” Not sure where the data came from, but it works just fine.
Thanks to “@i-copter dale”

Now on to the next problem to solve, what ever that might be.

1 Like