16.04 Ubuntu flashing?

I recently updated to Ubuntu 16.04 and I can’t seem to flash anymore - the GUI doesn’t install because it says it only supports up to 15.04, and the CLI doesn’t work as when I run ./flashall.sh, I get :

dfu-util: Device has DFU interface, but has no DFU functional descriptor
dfu-util: Cannot open DFU device 8087:0a99

I am using Emlid Reach and the firmware is 0.0.3. I have used both images, but they both give the same error.

Try running it as root

Hm, still doesn’t work. I get this error on the GUI,

.

I did update the firmware to 0.4.9 though, and was able to boot into windows and then reflash it, but hopefully 16.04 wil be supported soon.

Hi!

It is not a matter of supporting an exact version of ubuntu. We’ve encountered this problem before, but usually it’s a matter of chance, with flashing software missing the moment Reach boots.

Please, describe the exact steps you perform while flashing the the flashall.sh script.

Also, you can try to flash our beta.

So I downloaded the edison-image-edison from from https://files.emlid.com/images/ReachImage_v1.2.zip, and then I downloaded the tool from https://software.intel.com/en-us/iot/hardware/edison/downloads to flash with, downloading the linux version. I’ve plugged in the REACH, and my computer is able to find it and connect to it. Then I just run the ./flashall.sh script, where I choose the ‘use sudo’ option.

I run the installation, and there will be a message:
Unsupported OS
Detected operating system is not supported. Supported operating systems for this release are:
Ubuntu* 12.04 (Intel® 64), 13.04 (Intel® 64), 14.04 (Intel® 64), 15.04 (Intel® 64)

I click ‘next’ anyway, and then it is able to find the device and connnect to wifi successfully (I had previously set up the Reach already).

Then if I try and reflash it, it will disconnect, and then it will give the error I wrote above and say “device not located” (whereas previously it had found the device, as mentioned). If I unplug it and replug it, it will find it again but it will not have been flashed.

Same issue even with the beta image, too. I have managed to flash both image versions with the Windows/Mac programs and also Ubuntu 14.04, just not 16.04. It’s possible my 16.04 machine is missing some dependencies, (but sadly my only laptop is a 16.04 and I have to try make that work…)

You can try using the flashall.sh script which is inside the image archive instead of the GUI tool. It should work without those ubuntu version warnings.

ah, it works! Thanks. Originally it was not working because one of my directories had a space in its name and the script kept saying there was a syntax error when I tried to run it.

This is what I see after doing sudo ./flashall. Do you know if it’s possible to do the flash without downloading files?
Using U-Boot target: edison-blankcdc
Now waiting for dfu device 8087:0a99
Please plug and reboot the board
Flashing IFWI
Download [=========================] 100% 4194304 bytes
Download [=========================] 100% 4194304 bytes
Flashing U-Boot
Download [=========================] 100% 237568 bytes
Flashing U-Boot Environment
Download [=========================] 100% 65536 bytes
Flashing U-Boot Environment Backup
Download [=========================] 100% 65536 bytes
Rebooting to apply partition changes
Now waiting for dfu device 8087:0a99
Flashing boot partition (kernel)
Download [=========================] 100% 6062080 bytes
Flashing rootfs, (it can take up to 5 minutes… Please be patient)

Successfully updated in Archlinux from 1.2 to 2.2.7.
Just need to install dfu-util with :
pacman -S dfu-util

1 Like

sudo: pacman: command not found

any suggestions?

Are you on archlinux ? This command works only on archlinux.

If you are on ubuntu, just run :
apt install dfu-util
apt-get is not necessary at this time

1 Like

I am on ubuntu, thank you that worked.