14Hz post processing problem

I have tried to use GPS-only logging 14Hz with the latest update (2.2.1). Unfortunately post processing isn’t working. rtkpost_emlid_b26.exe either runs out of memory or, when I choose only 20 min the result is very bad (<5% Q1, strange positions).

Never had such a problem before with 10Hz.

Here are 30 min logs (convertet with rtkconv_emlid_b26.exe)

base.zip (4.0 MB)

rover.zip (3.3 MB)

That is the data from a referenz station I use to calculate the position of the Reach base:
base2 auri0380.zip (2.3 MB)

Hy

I have also collected for test 1 day at 1 hz gps + glonass but I’m not able to post process using rtklib (out of memory)

Francesco

There is a memory leak in RTKLIB, we have found the issue and will update Reach modules today and post-processing binaries within next few days.

1 Like

:+1:

Hello,

output should be base, sorry!

Thank you, is there an issue with 14Hz logging too? I got the impression that the results are by far not as good as 10Hz?

None that we are aware of.

Would the leak have caused this symptom:
https://community.emlid.com/t/reachview-beta-v2-2-1/4988/24

Quite possible. The update is already out there, you can test it. @egor.fedorov will update the 2.2 release notes soon.

The links in the post-processing docs have been updated to point to fixed RTKLIB apps. They go by the name of RTKLIB Emlid b27.

Please try them and report if the issue was resolved.

Thank you very much!
But it did not solve the problem. My laptop has 16GB RAM, the process stops when using approx. 450MB RAM.
A new file appeared: .hnav

@tobias-dahms It looks like it was not the problem that you are seeing. I was able to process your data without seeing the memory allocation error, but the observations of the base unit are looking really bad. Cycle slips everywhere.

Base station data is basically unusable. I have tried to process the rover data (which is good) against the reference station, but the baseline is about 57km, so no fixed solution. The track looks like you walked around something approximately 20m wide :slight_smile:

Ok, that is strange, had no problems some days before with another observation. The base was in the open field, only some leafless trees 50m away. The rover was very close to the trees in the beginning. I use the ground planes etc. for the rover and the base.

What could be the reason?

Can you try running it at 10Hz to see if the problem is really related to the update frequency?

Maybe some RF interference in that area?

Would you be so nice to have a look at this observation whether there the same cycle slips?

raw_201701241424_UBX.zip (9.2 MB)

I couldn’t process these files today. So this seems to be a problem with my laptop. I already rebooted the laptop. Strange.

Hy
I tried to use the latest version but

I received the error no position in rinex header

I have multiple rar file but usually the software can read all files if I put * on rinex obs of base station

Francesco

I just find rtkpost_emlid_b27 and rtkconv_emlid_b27 exe. Where to download the other of b27?

The track looks like you walked around something approximately 20m wide :slight_smile:

Yes, I walked around a stripe of our Sphagnum farming field trial :wink:

1 Like

Hy Emlid team
Can i upload my Static observation and Base rinex to try to post process ?= because I’m not able …maybe there is something wrong in my workflow

Thx

Francesco

Of course, Francesco :slight_smile: