Wrong OS version or set up issues

Currently trying to get my DJI drone to fly via raspberry pi.

running the version of Stretch from the EMLID website and its not giving me the options for a quad copter as shown in the documents section. It just shows the option for copter.

When I power up the drone the ESC’s buzz meaning none are getting a signal, if I wire the motors directly to the receiver I can make one move. This means they are getting power.

I am about to try a fresh install of the OS Image but could

it be possible that I just dont have an acceptable receiver? The controller does do PPM but cant get it to work.

Motors should do a musical start up if they are getting signals ok from the flight controller.

I am attaching images of my current wiring. The radio receiver is plugged on to the correct pins on the NAVIO 2 and then the motors just go on the next four sets of pins.

Any hints or tips would be appreciated. If I have to get a new controller then so be it, just dont want to spend the money when I have just wired something wrong or used the wrong software


Try iBus servo interface,


What GCS are you using? The last configuration should be done and written to your navio to make the copter properly config.
At the stage your are now, your copter is not ready to be used. Your are trying to fire up your motors before you have finisehd the setup guide.

As in iBus on the controller? Think it was set to it but I will check and reply again

Whats GCS? The only step remaining that I saw was to do with different programs thought it still should have responded to radio signals. Reflashed the SD card so will try running the pilot software again and see

1 Like

Ground Control Station.
Sorry, i see you dont have the full list of choices. Did you run this setup before ? (multiple times)
I see it doesnt perform the init test in the windows bottom right.
If it doesnt work after reflashing could you run this

sudo systemctl disable arducopter

And then

sudo emlidtool ardupilot

And post screenshot of both

As iBus servo plug on the FS-IA10B,


1 Like

Ok so reinstalled the OS then ran an update for an hour that mad all emlidtool commands not work so reinstalled it again and didnt run an update.

Currently same probelm.
No quad copter options and i tried the commands to disable and relaunch ardupilot but once I reopen ardupilot still nothing. I also cant get the SSH to work but the updating does. I also cant find it on my network using Fing

Should I try installing the older version of the OS?

It still is only giving me the copter and heli options. Could it be limited depending the signal receiver ?
Got the GCS software downloaded but need to do this first.

Also for Marc I added the plug to the I-Bus on the receiver. Made no difference

Starting from Arducopter 3.5 frame is selected differently, please refer to this:

No add: change from PPM Out (1) to iBus.

Navio end is S-Bus/PPM In (first plug)


I think i have it set to it sBus now. Is it sens or servo ?

Is this just to set the navio and receiver on the same frequency ?

Tried to update the parameter via GCS but it will not pick up my navio

Just keeps finding com port 1and not the device, with com port 1 it fails to connect and therefore cannot set to to be a quad drone

Not a sensor… so a servo.

Output mode: I have not the user manual and I don’t know this radio, but I guess S.Bus is a good choice.


Still not getting this to work as I still can’t connect properly to set the drone up as a Quad drone using the GCS just keeps giving me a connection error.

All help is appreciated dont want to have wasted nearly £200 on a thing I cant get to work :sweat:


Did you try to connect with WiFi or telemetry radio? Could you please post your settings from /etc/default/arducopter ?

current settup as shown

You didn’s setup UDP connection and I don’t see telemetry radio on your picture. How do you connect to GCS?

I dont know how to do that. I also dont know how to set it via udp or what telemetry is. I’m very new to drones

You can find information about connection setup in our docs.
If you don’t have telemetry radio, then the simple way to connect your Navio2 autopilot to your GCS is WIFI.
Connect your device to your local network or start in AP (access point) mode. After your PC and RPI with Navio are in one network, you need to change target IP in /etc/default/arducopter ( to IP of your PC.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.