Wifi Setup problem

Hello everyone!

I´m a new user of navio+ and i´m trying to setup a wifi network. I already installed the Real-time Linux for Rpi1 and connected with my laptop using SSH via ethernet. I also instelled the APM and I’m able to send telemetry info via radio modem.

What I can’t do yet is to setup a wifi network. I followed the instructions on http://docs.emlid.com/Navio-APM/configuring-raspberry-pi/ but i can´t get access to the network. I’m using a Airlink 101 wifi dongle model AWLL6075, wich is on the supported adapters list.

The RPi can find the adapter as shown in picture below, as well as the driver.

This is showed when calling sudo iwlist wlan0 scan command:

I also tried changing the ssid and psk of my network for emlidltd, but it didn’t work.
This is showed when calling ifconfig and iwconfig command:

and the network/interface and wpa_supplicant files:

As I said, I’m new using Navio+ and Linux, can someone please help me with this issue?

Thank you!


Welcome to our community!

The iwlist scan output makes us believe that a dongle functions as expected since it shows your network.
I think that the wpa_supplicant.conf seems to be just a little bit wrong. It appears that key_mgmt field must be set to NONE like this:


I hope it helps.

My guess is that you are complicating by using wpa-supplicant configurations.

Just configure your /etc/network/interfaces with something like:

allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-ssid "yournet"
wpa-psk "yourpass

This connects to a normal network with wpa security. If the AP you are connecting to has a DHCP server it is completely automatic, even if you take off your wireless dongle and put it back.

Hope I helped.
Paulo Neves@AirborneProjects

Thank you George!!

I tried that but it didn´t work, I also tried changing the ssid for default “emlidltd” and setting the WPA Password to “emlidltd” without results.

Thank you Paulo,

I tried several network/interfaces configurations, without solving the problem. I will keep trying, maybe I’m missing something else.

I am using wicd-curses. It is really easy to use and has always worked for me.
Install it with "sudo apt-get install wicd-curses"
Run it with "sudo wicd-curses"
It has a user interfaces, so it should be self explaining.

You’re missing a lot of the standard settings. Important values you should always know (not assume/leave blank) are ap_scan at the root level, and ssid_scan and mode at the network level. Also you should delete the other networks which don’t physically exist (emlidltd plus a couple of other developer networks hidden when you page down in the file).

Here’s a link to documentation for the wpa_supplicant.conf file:


Seems like a lot to read with all the crappy plain text format, but if you step through slowly it makes sense. Alternatively you can just scroll down to the bottom and copy some examples if you don’t have time.

p.s. some drivers simply don’t support certain modes, either due to hardware or manufacturer (software) limitations. One benefit of Linux drivers (if you can ignore the 1000% over complexity of having to be a developer just to use them) is that they are always open source so a software limitation is less likely. Use the iwlist frequency for example because many hardware limitations only occur on certain frequencies, it’s usually documented next to the frequency/channel.

It is very strange it does not work, as I have a similar setup running.
Can you post the output of

iwlist scanning wlan0

You may need to install wireless-tools.

What is the RPI . if 3 B why do u need a dongle - can’t not use the built in wifi ( apology if I am asking dumb question )

I had a problem but resolved by using
wpa_supplicant.conf , however i use RPI3 B with the built in wifi modem

clean up any network entries and just add only your network

ssid="Your network ssid"
psk=“Your WPA key passphrase”

than reboot
if the interface is not up
sudo ifdown wlan0
sudo ifup wlan0
sudo ifconfig wlan0
it has to show your DHCP address i.e 192…

This did the trick for me