WiFi - failure at entering into access-point

I purchased an emlid reach rtk-kit consisting of two modules. One works unconspicious (serving as base-station) the other makes trouble.

The troublemaker-modules was only possible once to login into the access point like described here:

Later on connecting to WiFi (into another AP) always failed - “cannot get ip”

I inspected many files and folders and found /etc/wpa_supplicant.conf messed with malformed charcters.
So every new GUI-based user-interaction to prepare the WiFi acces was written in the tail of that file after that suspect bytes. I erased the file up to the first entry (" network={ssid=“emlidltd” …) but without success. Wifi still not wanted to connect - worse - I found WiFi passphrases in I never had put in … strange …
Only copying the whole /etc folder from the working reack-rtk base-module to the non working rover module worked. This with the side-effect that WiFi setup is not longer editable by the user in the web-browser.

Additional I observed an issue similiar to file system corrupcy while looking in dmesg so now I consider the whole reach-rtk moule as defective. Yes I will reflash the module in the next week but I ask me: Are that modules vulnerable due to voltage drops? If so I would need to shutdown them every time before swithing them off…

Why don’t you reflash it with a fresh image?