Where is the Reachview browser version?

Ive seen references t the Reacview Browser version, but I cant find it. The App store only has the app (I have that), but I want a version on my MacBook Pro.
I can’t export the files on my phone (Android). Yes-I have storage enabled in the app.
It starts to download and then it hangs up on the selection. It shouldn’t take 10 minutes to export 3 points, I’m thinking.
Then they are not in the download folder as instructed.
This is goofy.
Ive looked everywhere.

If you open the app you should see the ip address for your receiver. Enter this in your browser on your mobile device or laptop that are on the same network and the reachview browser app should open.


Thank you!

1 Like

Hi, Brent.

Thanks for the info. Tried this, but it never opens up. I just get the swirling symbol on the tab that indicates it’s looking. Both the Emlid and my laptop are connected to the same network WiFi.
Am I missing something?


Can you try in “Private Mode” or “Incognito?”

1 Like

Just tried that and same result. I made sure my permissions were good, as well.


Let’s see if someone else joins in.
So to recap.

  1. You can connect to your Emlid device using the app on your android mobile device. (Is it a Reach M+, Reach RS2, or Reach RS+?)

  2. You can view the projects, etc, in your app but when you try to download them, they hang.

  3. You have tried to connect through the web browser but it fails to fully load.

  4. If you can connect through the app, updating the device is always the first step to make sure you’re up to date. That recently fixed a similar problem for me.

  5. Is your receiver close enough to your router?

  6. Are you using the receiver as a hotspot or connecting through a different network?


Hi, Brent,
Thanks for the assistance.

My receiver is Reach RS+
I can view projects, cannot export them.
Web browser does not load at all. I enter the coordinates for my Reach, it never opens.
Device is fully updated with latest software.
Receiver is close to the router
6. Receiver is connected to router through WiFi.

Can you try one more thing for me?

  1. Go to Wi-Fi settings on the receiver and turn hotspot on.
  2. Connect to your receiver directly from your mobile device. (Not through another router)
  3. Now access it through your app.

I am connected directly to the receiver. HotSpot is on.
I still can’t export. It does the export now, but it is not saving it on my phone. I’ve looked in downloads and searched for files, not there.
Permissions are on. I turned them off to see what would happen, the device asks me to turn them back on.

Now if you connect your laptop directly to your receiver hotspot can you access it through i.p. address


I get the message “This site is unreachable.”

Im in!
I did a restart of everything and now I’m in via browser.
Thanks for your patience.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.