What external compass works best with Navio2?

I never could properly run my 2 Navio2 internal compasses properly even after following all troubleshooting procedures (incl. on board mag calibration, manual declination, etc…)
I was up to now using as primary compass my internal compass #1, with compass #2 de-activated and it worked quite fine. (when both were activated I had “inconsistent compasses errors”)

After several hours flights and months of usage, mission planner now reports that my compass is “bad compass health” and I can’t get through any calibration method.
I tried de-activating compass #1 to only calibrate compass #2 but it did not change the fact I could not calibrate (no values are coming up in live calibration method and on-board mag calibration runs endlessly)

I upgraded to Arducopter 3.4 through the apt-get dist upgrade command and mission planner is the latest version available.

I wonder now if the only remaining solution is to use an external compass and de-activate the internal ones. Can someone advice me a reference that works robustly with Navio2?

Thanks in advance

newer hmc5983 works fine for me (as well as hmc5883L did)!

Thanks for the advice!
I found this one: https://www.amazon.fr/WINGONEER-HMC5983-capteur-Compensation-température/dp/B01H71276Y/ref=sr_1_3?ie=UTF8&qid=1478814627&sr=8-3&keywords=hmc5983

Would you know where to find the installation procedure? (wiring on the Navio2 I2C port + parameters in mission planner I believe?)

Thanks for your support

wiring on the Navio2 I2C port:

i2c plug on Navio2 should be the same as in Navio+;
(coming from the power connector: GND, SDA, SCL, VCC)

MissionPlanner works out of the box! tick externally mounted, set orientation and calibrate!

1 Like

Crystal clear Benedikt!
Thanks for your help

I was reading this post and i would like to add this. I had some problems with compass calibration (very high offsets), i tried Mission planner and APM planner, i was almost giving up when i decided to try Qground control, that made a huge diference, i have had my compass calibrated on the first attempt. Windows 10, Raspi 2, Navio+. Mounted on a hexa S550 frame. I hope that works to someone else.

1 Like

Thanks for this advice i ll give it a try. In the meantime the external compass resolved my issue but i cannot use the internal ones anymore at the moment due to this high offset values

Ok, please let us know if it works for you.

I tried using QGroundControl today.
It connects and works fine… except the accelerometer calibration that just doesn’t record the results.
I can perform the full accelerometer calibration till the end. It even says I need to reboot my autopilot for the changes to be taken into account… but when I reconnect my accelerometer remain as if it would not be calibrated.
And without accelerometer calibration I cannot run the compass calibration… I am turning in circles…

Hello there!

The issue was fixed a couple of days ago. I suggest rying out a latest daily build that you can get here.

Thanks George
I could now run the compass calibration following installation of the daily build of QGC :slight_smile:
By the way I have seen there some slight improvements to the GCS which are great (e.g. parametric video UDP port)

Performing the calibration with QGC did not show better results than the “on board mag calibration” of mission planner.
By performing the exercise several times, I could save internal compass #2 and use my external compass #3 (that uses chip hmc5983)


These use the same algorithm (onboard calibration). That’s why the results are the same.