Weird output during telemetry session

I’ve been using wifi for all my work, but I just switched to telemetry. I bought the 3DR transceivers and hooked it all up. I could connect and communicate just fine, however during my SSH session I got this nasty output of junk (see image). Is there a way around this? Note: I use rover.


This output is the Navio screen. As soon as you valid the start ardurover string, you have this output on the screen.

You can hook your Telemetry Radio to the UART to have telemetry data.

When all your settings are OK and you choose to autoStart the Ardurover (edit the etc… file), Navio screen will be with the normal pi@navio prompt.


The radio is connected to the UART port.

I set it to turn on automatically now, and everything gets written to the startup_log. The startup_log file still has all that junk in it though. Is it possible to eliminate that? It’s just annoying to look at.

This is APMs telemetry going to stdout aka the console. If you leave out the -A option or provide a unusable/wrong telemetry channel, APM falls back to stdout for telemetry output.
Just enter -A udp: or -A tcp: even if you do not plan to use it and the garbage on the console should be gone.