Verizon SIM card does not work in RS2+

Still trying to access NTRIP corrections via a Verizon nano SIM card. When I insert it into the receiver, it briefly shows the signal bars on the menu, but after a while they disappear and I cannot get mobile data to turn on.

Any insight on this?

Good afternoon Bill
I am facing similar problem like you but could manage mobile hotspot as I need to work on filed.
It may be solved automatically or may not , I even do not know.

But if you have urgency to work field then I would like to suggest you to use mobile hotspot/Portable Wifi where you may insert your SIM and the receiver will receive network data from your wifi and will receive correction from Base.


Hi everyone,

We’re in touch with Bill regarding this issue over emails. We’ll continue the investigation there to keep all of the info in one place and to share the sensitive info privately.

If you have any issues with turning the Mobile data on, please check that:

  • your SIM card is working with the appropriate network (up to 3.5G for RS2 and up for 4G for RS2+)
  • you have inserted the APN, several available ones from your provider
  • you have inserted the authentication credentials if the SIM requires it without any issues
  • you have tried this SIM card in another device and it works fine

Additionally, you can check another SIM card in the same Reach device. If the issue persists, generate the full system report on your device and send it to us at We will take a closer look at the behavior.

1 Like

UPDATE: still not working with VZW SIM card.

We verified the SIM is working in another device on the network.

Emlid Flow cannot see the SIM card, installed/removed/re-installed multiple times

APN we are using is “vzwinternet” as recommended by Verizon.

Any ideas on what to try next?


My RS2 will not work with Verizon, go with AT&T, it has to do with the system verizon uses

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.