Using Reach without WiFi access point nearby

I am planning on using a Reach GPS module with a rover that will have no WiFi access point nearby for the most part. The device works just fine when it is connected to a WiFI access point, and also works fine if I tell it to enter hotspot mode then bring down the access point and connect to the Reach’s network.

But, if I boot up the Reach without an access point nearby that it knows how to connect to, I cannot access ReachView. It does create it’s hotspot network reach:XX:XX, and I can connect to reach.local:5000, where it prompts me to connect it to a WiFi access point.

Don’t know if this is at all related, probably not, but thought I would share it anyway. I am also still able to SSH into it. I did a bit of digging around, and I noticed that some systemd modules were not loading correctly, namely nginx (log sub-directory is non-existent), but I later noticed that the same modules were not loading when the system was working properly as well.

ReachView version: v2.4.0-r0 (updated/installed again today)
Firmware version: 2.3 (downloaded and flashed again today)

Is is possible to have the Reach enter hotspot mode on boot? With the intended application of the GPS, it would be a nuisance to have to connect it to a WiFi network every time to get it started.

Any help is greatly appreciated.

Is the LED green?

Try deleting all wifi networks from the ReachView settings and see if it will start it’s own hotspot on boot and let you access ReachView on the normal port 80. If so, then add your WiFi network and try again.

I would also look for a strange line of funny characters in
and delete that line if it exists.

Thanks for the reply.

The led alternates between green and magenta.

Deleting the network and restarting it didn’t seem to change anything, still only able to access it via SSH and port 5000. wpa_supplicant.conf seems pretty clean, no characters that shouldn’t be there.

If you delete all Wi-Fi networks from the wireless settings menu, then it will create a hotspot every boot.

From the docs:

time sync in a hotspot mode will produce green/magenta blinks

So if you take Reach outside or by a window, it should stop blinking and go solid green.

Solid green LED currently means Reach was started in hotspot mode.