Using Reach with Android

Has anyone had any success using Reach with Android? Basically, I have been using Reach as a rover connected to my Windows tablet and works well. I was wondering if it can work with my phone too, since Android is able to ‘Allow mock locations’.

There are apps on Google Store that allow the phone to use location info from NMEA messages received from external GPS devices via its microUSB port like ‘You Are Here’:

For my phone, I connect my phone to Reach (my phone is acting as USB host) and broadcast a wifi hotspot, Reach connects to my phone’s wifi (I need Reach to connect to an NTRIP server) and I access ReachView directly in browser by it’s IP address stored in my phone’s hotspot settings.

What I’m hoping to try is to get reach to output locations via USB so that I can use the locations as mock locations on my phone. Alternatively, would be good if there’s an app that can use mock locations from a TCP port. Tried googling but couldn’t find any apps that do that. :(disappointed:


We are working on this. In the next release we are going to have Bluetooth connection to Android smartphone to mock coordinates.


Thanks Igor. you guys rock!

Would it be possible to run RTKGPS on the Android phone and get the solution stream from reach over TCP ? Reach sending NMEA data to RTKGPS on phone over wlan? RTKGPS can then pass it on as a mock location for other Android apps to use? As a workaround while waiting for the BT support?

I am not an expert in RTKGPS+, but after a quick glance I believe that it is not possible to use it as a proxy.

I have played around with this bit further…

RTKGPS+ is actually just an Android app that wraps RTKLIB and it offers an option to receive rover data from a tcpserver, USB or bluetooth. So basicly, if one can configure RTKLIB to receive location from Reach, one should be able to do the same on RTKGPS+.

My only concern would be the IP configuration of the phone having to be a wifi hotspot for Reach to get online, but at the same time to access Reach. Also one needs to take into account that RTKGPS+ is based on p9 patch level of RTKLIB and at least I didn’t manage to compile it with the later versions… That means that RTKGPS+ can not process the rawx signal coming from M8N as that support was added only in later versions which means that the solution math needs to be done by Reach.

But as soon as you have new patch of the Reach kit’s available, I’ll test this my self. It should also work as a solution on a setup edmund89sg was mentioning.

I just wish that it happens before the snow melts here as a snowy field is a perfect test platform for precision agriculture
applications :slight_smile:

Yes you are right. I have tried sending the NMEA to tcpserver on port 9000.

On my RTKGPS+, I tried connecting to (the NMEA stream on my Reach device). I actually got a signal, I did not know where to output the solution to. The default in RTKGPS+ is localhost:1020. And then tried output to mock location, but no luck. If only we could wrap strsvr on Android to output to mock locations, that’s how I use it for my tablet, strsvr will stream the NMEA to virtual com port and my QGIS can connect to the COM Port…

Sorry that it took a while.

Somehow managed to broke the tcpserver option on my desktop rtklib, while trying to reconstruct the
issue you mentioned. As I don’t have my reach yet, I use a desktop Linux system and a M8T USB thing
to emulate one.

I recall reading somewhere that the mock location output of RTKGPS+ does not work for example with
Google Maps? Same issue with your QGIS perhaps? Have you tried the mock location with any other
app using location data?

You would need a virtual serial port solution that would wrap a TCP stream in it. There must be one available somewhere!

just to understand: when will approximately be available the new release with BT?


We are working on this, trying to release it next week. It is hard to predict as sometimes we have to spend time on more important issues.

Ok, thanks!

Hi Igor, please keep us posted on the bluetooth integration developments. At the point it is working, we’d like to test it right away. tnx.

Hi Thomas,

Will do! Really want to get this working for you, sorry about the delays…

Reach Bluetooth support just made available via in-app update. Proper release post and docs update coming tomorrow.

Quick instructions: enable BT on your tablet, make it discoverable, open ReachView and go to settings tab, hit “scan”, as soon as your device shows up - click on it, you will receive a pair request on your tablet - accept it, go to “bluetooth gps” app - settings and put a tick in “connection workaround”. Also set “bluetooth” as output option and “NMEA” as format.


Well done. A very useful and necessary feature.