Using Reach M+ with Navio2 on USB

Hello
I tried to use Reach M+ with Navio2 board.
It works fine in UART as I can see the 3D RTK Lock, however, all my attempts to attach the USB failed.
In Arducopter I made sure to add -E /dev/ttyACM0 and I can see ACM0 in /dev/
I tried two options with -B /dev/ttyAMA0 -E /dev-ttyACM0 and only with -E /dev/ttyACM0.

I have enabled on USB-to-PC position output on Reach M+ and made sure to enable the second GPS on Ardcupter parameters, but still, I cannot see the lock on the copter, although Reach M+ connects to 17 satellites.

Any hint about this?

Another weird thing is that when I connect on UART, I can see the 3D RTK Lock, but the number of satellites reports in GQgroundControl (9) is lower than the number of sats reports in Reach M+ applications. Is this normal?

Thanks
Anis

Any help on this?

Hi Anis,

It looks like you’re trying to set up Reach M+ via UART as a first GPS and M+ via USB as a second.

As far as I remember, the QGroundControl doesn’t allow 2nd GPS configurations and doesn’t show it on the status tab. Have you tried to do the same thing with Mission Planner? Please note that you need to configure GPS2 setup via Serial 4 in this case.