Using mobile phone for Internet and for ReachView at the same time

Do you have any recommendations for a service provider or what I should be looking for / avoiding? I’m considering a SIM card for one of our RS2 receivers, but this is a bit foreign to me. The reach RS2 uses a nanoSIM card and my work cell phone uses a microSIM card so I wasn’t able to test it out. Should I be concerned about compatibility?

Thanks!

Hi @gleb.gira,

I ran into this same issue with our new RS2 as well and I believe that I followed the guideline exactly. I could get the unit to connect to the mobile hotspot without issue, but I could not connect to ReachView v2.20.x after it was connected to my mobile hotspot. I confirmed the hotspot was working by connecting my laptop to it. In the mobile app, it will not find the receiver. I am using a Samsung Galaxy S8 with AT&T as a provider.

Do you have any other recommendations or knowledge of issues with certain phones or service providers?

Has anyone had success with this using the v2.20.x with an RS2?

Thanks!

Works awesome

1 Like

@davehofer1993

Good, so that eliminates the software being an issue . Would you be open to sharing what you use for a phone and service provider? It may come down to the only variable being the user :smile:

Ha! When it comes to mobile service providers, just pick your poison, they all suck! (Just like cable, internet, insurance providers) ; )

I use Verizon, but had AT&T before hoping Verizon was better as it’s hyped so much as being better, but from experience is no better and even worse. Will change back to AT&T more than likely. Central USA.

1 Like

@davehofer1993 I should have been more specific in my question. I am wondering if anyone has had success using the RS2 and ReachView v2.20.x through a device (i.e. tablet/phone) that is both providing the mobile hotspot and accessing the receiver through the app. Hoping your answer is still yes :crossed_fingers:

I miss read that I mostly only use LORA and works good for me . Sorry

1 Like

Had some issues with earlier version (prior to 2.20.1) when i had the sim installed.
But havent tested with the 2.20.4 yet

I my region 3G is really poor so i need to use the 2G which is excellent. Make sure you pick a provider with best coverage.
Oh and 2G with RTCM at 1hZ ntrip works just fine. Speed was not an issue during my tests in 2G only area.

2 Likes

Sadly I am not of much help, as the choice of provider is a local one.

1 Like

Hi Jared,

Could you describe at what step you have issues exactly?

Does LED on Reach RS2 indicates it is connected to a Wi-Fi network?

Do you see Reach RS2 in the list of devices in ReachView app?

1 Like

I am constantly connecting my RS2 to the phone via mobile hotspot. I am using only one phone, which is a mobile hotspot and a controller. Haven’t had any issues. I know, that some of the smartphones still has the bug, where Reachview can’t see the unit, but you can open the Reachview via browser (by using RS2 ip address). A colleague of mine has Blackview BV6500Pro and he had this issue previously (I think it was with v. 2.20.2).

Maybe you try to open Reachview via browser? Do you see in your Samsung, that you have actually a device connected to your hotspot?

1 Like

I have Reach RS+…
Tell me, please which phone is work fine?

I’ve tried everithing without succes.
Maybe the problem is with my phone, Motorola E4 Plus…

But… I need to tel you: such trivial thing, like connection of receiver and control software, does not deserves time for discussion.
Integrators need to resolve this issue with more robustness.
Thank you for your good intentions.

Kind regards,

Could you tell please at which step of this guide you have issues?

https://docs.emlid.com/reachrs/common/tutorials/connecting-to-the-internet/

I’ve do this steps:

Connecting to ReachView¶

  1. Connecting to Reach with iOS/Android device
  2. Get the app from Google Play or Apple Store
  3. Go to Wi-Fi settings on your device
  4. Connect to Reach hotspot. It appears as reach:XX:XX
  5. Enter password emlidreach
  6. Launch ReachView app
  7. Choose Reach from the list

  1. Go to the Wi-Fi tab
  2. Choose Wi-Fi network
  3. Connect to a hidden network

Steps for mobile hotspot

If you connecting to mobile hotspot do the following steps:

  1. Enable Wi-Fi hotspot on your mobile device
  2. Check that it has the same name and password as you filled in the previous step
  3. Now reboot the device with the Power button
  4. Reach should connect to your hotspot during the next boot
  5. If the connection is successful, you will see blue LED is blinking slowly (THIS BLINKING IS OK…)

Go back to ReachView¶
Connecting to Reach with iOS/Android device

Connect your mobile device to the same Wi-Fi network as Reach (THIS IS THE PROBLEM: How to receive Internet signal by wifi, in the phone from itself? My phone hasn’t such possibility. Every time when I start WiFi to receive Internet, HOTSPOT shutting down, and vice-versa…)

Scan for available Reach devices

Choose Reach from the list in the app (THERE ARE NO ANY RECEIVER IN THE LIST, FOR HUNDREDS OF SCANNING…)

Ah, I see.

There’s no need in enabling Wi-Fi on your mobile device if you use it as hotspot with Reach.

Once Reach’s blue LED is blinking slowly, go to ReachView app on your mobile device and search for the devices. You should see Reach in the list.

In case you don’t see Reach in the list, then it must be something with device’s scanner on your Motorola E4 Plus. Unfortunately, this sometimes happen to some Android devices, there’s not much we can do here.
You can use Fing app to determine the Reach IP address and go to ReachView via a web browser.

Thank you…
I think also that Motorola is the reason…
I will write you when I try another phone.

Regards

AT&T it is. I had success today using a mobile hotspot, but I am guessing that a SIM card would speed up and simplify data collection. Thanks for your response :slightly_smiling_face:

@dmitriy.ershov

The LED on the REACH RS2 was solid blue and a quick look at my mobile hotspot connected devices confirmed that the receiver was connected. The issue was that the Reach RS2 was not showing up in the list of devices on the mobile app.

When I tried connecting through the browser, I was using the IP address 192.148.42.1 that was called out in this document https://docs.emlid.com/reachrs/common/tutorials/connecting-to-the-internet/
No luck there either

However, when I went back to see the devices connected to the mobile hotspot, I discovered that the IP address was different. It was 192.168.43.177 - I typed that into the browser and voila!

@cobatz I was having the issue with my Samsung Galaxy S8 and I posted my solution above. In summary, I was not able to connect using the mobile app as the Reach RS2 would not show up in the list of devices. I was able to use the browser to connect to the ReachView using the devices IP address which was NOT the one that was listed in the EMLID documents. To find the receivers IP address, I simply went to my phone’s mobile hotspot and under the list of connected devices I was able to look at the details for the device and it was here I found the correct IP address.

I hope this helps and you are able to find a solution.

Thanks @jurijs.jeshkins

This tip got me on the right track and I was able to connect to a mobile hotspot and to ReachView through the browser today.

The issue that I had yesterday was that I did not have the correct IP address. I was using the IP address listed in the Emlid document https://docs.emlid.com/reachrs/common/tutorials/connecting-to-the-internet/

The actual IP address for the Reach RS2 was different and once I figured this out, I was able to connect!

2 Likes

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.