HI @emlid5

As the previous attempt to turn off the 2…4Ghz WiFi and switch to ATT data only sim card failed. I wanted to try using Ethernet over the OTG which would be great since i can still use all the TCP options for getting data from the base allow it to get correction over the internet and stream RTCM correction out over TCP as well.

So I started with a simple USBC ethernet ( and all worked great, so I became griddy since now it all works but it drains the battery, since the ethernet switch it is connected to is a POE (you know where it is going) I stated looking for a USBC OTG Ethernet that will take POE and charge the base as I use it and found that one ( but for some reason I got no internet connection with it digging into the logs it looks like the base does recognize it when i just connect it to the usb but when i connect the other side to POE the base is losing it. the adapter itself works with the base if I don’t give it POE but just regular ethernet.

see logs:

ReachBase_ReachRS2+_20230726_SystemReport (1).zip (2.4 MB)

please let me know if there is any chance to get this setup to work.

1 Like

Kept trying more options, it looks like when the base is charging it is kill the OTG.

I connected this one ( which instead of POE has an ethernet and power separate power input. when just ethernet is connected, I get full connectivity and all works while the base is discharging, once I connect the power as well it appears that the ethernet is gone the the OTG status changes to disconnected.

1 Like

I have also tried all this with different adapters , same result when connecting power it looses internet

Hi @guyz,

We don’t have direct support for such adapters but a while ago, we tested Reach M2 with the TP-Link UE200 and it worked. We didn’t change anything in the software ever since so I suppose it should work with Reach fine.


HI @liudmila.slepova

I found many USB to ethernet that works the issue is a bit different.
My intent was to find a POE ethernet that can both give ethernet connection and keep the base running, but i found out that the base OTG doesn’t work when the unit is being charged for some reason.

so for example when using this unit:

when connected to regular ethernet it will work and get the base connected and running while draining the base battery, but once connected to POE port on the other side as soon as the base starts charging it loses the ethernet connectivity.

if you can solve that issue in the firmware this adapter will be able to both charge and provide ethernet.


1 Like

Hi Guy,

Ah, I understand now, thanks for specifying this.

We don’t have such a device to test but we can check the Full system report from the receiver to see if we can find anything explaining why it works this way. Please send it to so we could analyze it.

1 Like

sorry for the delay, full report sent over email.

If the price of the unit is an issue I can fund it for you… considering 35$ compered to a 2600$ unit I think I can live with the extra cost… send me your full address.

Hi Guy,

Thanks, I received the report! Once there’s any news, I’ll let you know.

I bought one just now to try , Ill keep you posted.

Hello ,tried it , same result poe in only powers the unit ,you have to change to standard Ethernet to connect to network, so there goes $48 :thinking:

Hi Guy and David,

We checked the similar setup ourselves. It looks like we can’t support OTG and charging at the same time due to a hardware restriction.

1 Like


I see you now have RS3 will it have the same problem?

Let me check this with the devs.

Since this hardware part of Reach RS3 wasn’t changed, the receiver won’t support it.

I have tested it on RS3 , like was said , “no go”

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.