USB Telemetry Receiver not recognized as USB device

Windows 10 is not recognizing USB Telemetry Receiver device.

I have installed the driver for it. It is identified as Silicon Labs CP210x device. I installed CP210x device_Universal_Windows_Driver for it. It was identified by Windows few times in the beginning. But now, each time I disconnect and then connect it back, Windows does not recognize the USB device. I tried to uninstall drivers, disable/enable device, reboot, try other USB ports but nothing helps. I keep getting the message Unidentified USB device. Any help will be appreciated.

My FPV Radio Telemetry Ground Module was defective. I tried on a different laptop and it did not work there either. So I replaced the Radio Telemetry Ground Module and it has been working since.

What exactly are you connecting to your PC via USB?
Is it your Reach RS2 receiver? If so, why?

Hi Sheehan,

What device do you have? Why do you connect it to a PC? For position output or something else?

To have all the needed drivers, you can install the Flasher tool on your PC. But I would really like to know your final goal in this setup.

1 Like

I have connected my FPV radio telemetry Ground Module to my laptop (which I am using as a Ground Station) via USB port. I have mission planner installed on this laptop.

1 Like

So, the issue isn’t related to Reach devices? I see everything seems to work fine now, but want to make sure.