USB disk versus SD-Card


I have a Navio2 with Rpi 3. As I have random log problems, I had a try with Raspbian image on an USB drive.

My Rpi3 is patched to boot from USB,

Fresh Navio2 img is installed on the USB drive with Etcher,

/boot/cmdline.txt and /etc/fstab are edited for USB Boot.

ssh connection is fine, Ardupilot config is OK with emlidtool (no error with sensors before enabling arducopter).

UDP Mission Planner connection is ok but Navio is chasing Horizon around the planet. Even after calibrating Accelerometers and Compass, Horizon is still moving in the HUD.

Here is a log during my second try (Horizon is moving).!AlTaMbgj9DGH0XopXwVk_vSXp8FC

I aborted settings before Acc and Compass calibration, but the result from first try was the same.

I have a Rpi3+ on order. I will try again with it.




Some news, but no solution:

Disk is Sandisk Cruzer Fit USB flash drive 8GB,

I moved it from USB port to another one (same result), I moved it at the end of a 12" extension, same result.

I also put a shield between Rpi Usb chip and Navio without success.

3DR telemetry unit is on USB0.


Hi Marc,

I’ll look into your log and then write back to you.


There is another log, from boot to shutdown. Configuration is Quadcopter (default), no acc or compass calibration.!AlTaMbgj9DGH0XvyWBITSLZTQ2np

I unplugged USB telemetry and removed the Telem /dev/tty/USB0 setting, no change…

When boot is from SD-Card, even with USB drive inserted, Gyro and Acc are OK.


Hi Marc,

We’ve reproduced the issue and can approve that with booting from USB drive data transmits unevenly.

We’ll try to resolve it. However, I’m afraid, I can’t provide you with ETA.

No problem,

Thanks for your help,


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.