USA SIM Card that actually works on AT&T [RESOLVED]

NOTICE: Be patient, the wireless network will not activate right away, you may have to turn on wireless network a couple times and wait a couple minutes. Its not instant. Try installing the SIM, resetting the Reach unit, making sure data roaming is enabled, ensure the APN is entered correctly, and turn on mobile data, might have to attempt to turn it on more than once. Just give it a minute and after that it works great every time I turn the unit on.

I have only tested on AT&T network because it is the only one available in my area, but they were very diligent in helping me get this working when Emlid and AT&T basically said there was nothing they could do.

The SIM card needed to Run AT&T, T-Mobile, or Verizon in the Emlid Reach RS3 LTE modem may be found here:

To confirm, it’s the SIM with APN

If anyone needs help, Reach out to Maria,
Maria Danag,
You can tell her Carlo sent you, we’re like best friends at this point.

The standard SIM for spectrum on Amazon did not work for me. The SIM that worked can only be found on their website. (as of the posting this)

I tested four different SIM cards, and just because they worked in an iPhone AND a hotspot does not mean they will work in the Reach RS3.

The people at spectrum said to use code “REACH” as a referral for me, and so they know what you are using the SIM for to ensure you get the right one, but I’m not sure where you put the code or how you use it.

Best of luck, and please report back if this worked or did not work for you, or any tips and tricks learned along the way.

Have a great day,


Hi Carlo,

Thank you for sharing it on the forum! I’m sure it will be useful for other people.

1 Like

Update: sent another SIM card to test in the Emlid Reach RS3, and it is confirmed working.
Spectrum SIM

Currently the process for purchasing this SIM card is to purchase and check out with the only SIM available on their website, and message them and let them know you need the “TAG SIM card” with APN “”.

The difference between these is the TAG is $9 per GB and the Puffin is $14 per GB.

I have had much better luck using Emlid caster instead of LoRa for larger sites.

Report back if these SIMs do or don’t work for you.

Have a great day,


Hey Carlo,

I reached out to Maria as instructed and she has be very quick to respond and sent out a new card. My Reach RS2+ shows that mobile data is connected and using data but I’m not having any luck receiving corrections. I’m using the option to receive corrections via NTRIP which works just fine if I’m connected to wifi or via bluetooth from my phone but it’s just “waiting on corrections” if I’m not connected to either of those and have mobile data turned on. Any thoughts?

Thank you for all your work on this!

1 Like

Hi Mike,

Can you insert this SIM card into your phone, share its hotspot, and receive corrections like this? It’s definitely unusual that you can turn on Mobile data but can’t receive corrections.

Please also share the Full System report with us at when the SIM card is inside?


unfortunately my phone uses an e-SIM and cannot accept the physical SIM. I’ll try to get that full report over to you shortly.

Thank you!

Hi Mike,

I have not run into this scenario, and I am sure you have tried the required steps.

  • installing the SIM
  • ensure the APN is entered correctly
  • making sure data roaming is enabled
  • turn on mobile data
  • resetting the Reach unit

Does the unit show the signal bars and the LTE symbol on the top left of your phone in the flow app?

Have you tried putting your phone in airplane mode and turning Wi-Fi back on to connect to the receiver through the flow app and seeing if this changes anything?

Are you using Emlid caster or a different NTRIP service?

I would recommend trouble shooting by swapping things around and getting your receiver set up on Emlid caster (free) as a base and seeing if it appears online on your caster account login.

I wish I could be of more assistance but this is what I would try.

Please keep us posted on what you figure out.


Well I’m still stumped. Maria is still extremely quick to reply but still no solution (no pun intended).
I’ve tried everything listed above but nothing has worked thus far.
I had the TAG card and was able to turn the mobile data slider on in Emlid Flow but was never able to receive data. Maria then realized that I should be using the Puffin card and sent one out to me. I got that in the mail and now cannot even get the mobile data slider to turn on. I’ve tried both the “” APN as well as “puffin” with no luck. At this point I’m not entirely sure it’s actually a possibility…

Any other thoughts?

Maybe get yourself a 5G mobile Mifi hotspot device?

1 Like


Thank you for testing with another SIM card. Can you share the Full System report with us at We will take a look at it with our development team to check if there’s anything else can influence such behavior.

1 Like