Upgraded to the new Emlid image 6 April, and WiFi no longer works

Friends at Emlid,

Last night I upgraded a working Pi3/Navio2 to the latest Emlid image from your website. Now I cannot get the WiFi dongle that had been working previously on the Pi’s wlan0 interface to work anymore.

What changed, and if so, how may I adapt to the change so I can continue to use WiFi to configure and test my quad.



“wlan0” is now called “intwifi0”;
you can check with “ifconfig”!

1 Like

Hello there! It’s now intwifi0. I’ll update the docs to make it more clear.

1 Like

Ok, thanks gentlemen. I had the WiFi dongle working for months on wlan0 - I was not using the Pi’s internal wifi interface because it did not have enough range.

Does this mean I need to use interface wlan1 for the external WiFi dongle?

Thanks again for the quick help.


you should see your dongle show up (and it’s name) if you type “ifconfig”;

Ok, I think I am understanding that what used to be “wlan0” is now “intwifi0” right? I used the ifconfig command several hundred times in the past 8 hours! Just never thought to try the intwifi0 interface.

Just tried intwifi0 and that interface doesn’t work for me either. The only interface that works is eth0 and the console on HDMI.


are wifi parameters correctly configured?
something like:

Got it working now. intwifi0 is still the internal wifi interface. I disable that one and configure wlan0 with a static IP and install the external USB dongle.

My most recent anxiety was caused by having a # character still inserted at the beginning of the password in my wpa_supplicant.conf file. That’s why only the eth0 interface worked. Sheesh.

Now where was I last night when I began this…oh that’s right - getting volts and amps from the power module!

Thanks all for your patient help.


1 Like

Woahhh what? for development purposed this is a pain. Are you kidding? No offense to the devs, but if someone has googled around enough to understand the terminal, using ifconfig, and setting up another wireless dongle then why do we need to rename wlan0 intwifi0. I mean not only is the name a even bigger pain to type in the terminal, you don’t just change standard Linux practices like that seemingly for the heck of it. sigh

1 Like

I think it is reasonable to distinguish the internal interface from the external ones.

i assum it is a way to keep the setup of ez wifi broadcaster easy for rpi2 and rpi3!
*correct me if i’m wrong

1 Like

@panky is right on the point as always. This was a needed change to support Wi-Fi broadcast. As a matter of fact, I was not a fan of the approach either. But actually it makes sense to distinguish internal Wi-Fi and external. After all, everything is obvious after ifconfig. I’ll update the docs to make it more clear.

1 Like

I see and appreciate your honesty. Just brainstorming here for ideas, would it be possible to make that a variable instead in the ez wifibroadcast start script or something?

Oh i can see there were some situations for changing the name of the interface.
Anyway, i think at least if you were to change the name, you guys should leave the tip to change the name back to original.

P.S. Anyway i saw the many good changes in this release, and happy for the good changes, such as the way of setting system configuration.

Guys, thank you for your suggestions and the feedback. We’ll try our best to incorporate them and make your experience more pleasant.

The interface’s name change is tricky, though. So I guess we’ll leave it as is for the time being and make more tips about it in the docs so no one could miss it.