Updating reachview fom 2.0.9 to 2.2.5

Trying to update reachvew 2.0.9 r0 to 2.2.5 r0. This is my 3rd reach. I did the 1st 2 awhile ago and they are working but this one wont update. Have one more to go so want to get this one done.

Hi Jim,

Could you provide more information about problem?

I did the firmware update now trying to update reachview. It appears to try to do the update and then says update encountered an error Skip update


Still trying to do this update.

2 screen shots of what happens.


Jim, try to flash v2.3 and write here about the result of update test, please.

Cant get v2.3 to work.



Please follow this guide, there is new flashing software now:

Good morning
Whats new about this looks the same to me?

This is the same as it was months ago and I could not get it to work with windows 10 and still does not work for me. The intel flash program in the picture has worked for me untill now?

Hello Everyone

I finally figured this out and got it to work maybe I am just to thick headed some times.
The problem for me was that I followed the link above from Igor. For Windows 10 the way I got it to work was follow the firmware flashing document at that link but after doing the Choose Image to flash screen it would start and then this screen comes up

You have to unplug the reach unit and then plug it back in then the program does the update.(that screen does not say to unplug and replug which is misleading if you click on the troubleshooter it opens a web site. I must have tried 30 times before I figured this out.)
Also when the update is done it reboots the reach and confirms the install and comes up with this screen

When you click on Finish you are done the reach unit does not reboot after this you have to do it manually. Also when you click finish it opens a website but closes the installer, I just closed that web page and carried on.
The above should be added to the documentation to make things clearer.

1 Like

Thanks for you additional comments here Jim. These are practical tips which provide a practical insight to process described.



I was getting frustrated trying to flash the last two flash versions. The Intel flash program was crashing at about the same point. in the flash process.

Final solution for me… I kept trying different USB adapters to Reach. They were consistently crashing the flash process. After trying about 5 or 6 adapters, i found one that worked every time. I labeled that cable adapter for Reach flashing. I have no idea what can get messed up with such a short cable, but for now, I can do the flashing successfully.