UPDATED: RS2 Bizarre rebooting issue after gaining a FIX

Hi there,

I’m having one hell of a time with our RS2, which had been previously operating fine up until this month.

I’m suddenly finding that there are two different issues, which sometimes appear to randomly affect each other.

Issue 1:
Mobile data keeps turning itself off. The unit will startup with mobile data off.
Sometimes the toggle switch (in the Emlid Flow app) doesn’t appear to function. Eventually, it may let me switch it on.
Sometimes, when I turn it on again it will begin receiving NTRIP connections (demonstrating that data is working) but then the unit reboots itself. When it comes back up, mobile data may or may not have turned itself off again.

Issue 2:
On other occasions, when I am able to turn on mobile data without the unit rebooting itself, it will receive NTRIP corrections but once it gets a FIX, it’ll be settled for around 10 seconds and then the unit reboots itself and we go through the whole routine again. When it comes back up, mobile data may or may have turned itself off.

Sometimes this crash / reboot is silent, but on other occasions it first beeps (the ‘fix achieved’ low-high beep) several times before rebooting.
I note that someone else experienced this beeping reboot problem a few years ago: Reach RS 2 Reboot

This issue persists whether I’m using the Emlid flow app, or our older data collector with SurvCE software.

I have tried:
Using different NTRIP servers. It exhibits the same problems.
Reflashing the firmware (currently on 31.8). Again, no change to this behaviour.

We’ve got a Vodafone UK SIM. The unit was last used successfully on 15 Jan 24, and hasn’t been tried again until this week.

Has anyone else experienced anything similar?
Is there a source of older firmware files somewhere, that I might try rolling back to a previous version?

Many thanks in advance for any pointers!

1 Like

Hi Gareth,

Welcome to the community!

I’ve found that Vodafone is switching off its 3G network in the UK. Since RS2 supports only 3G, I think maybe it could be the reason for interruptions. But it’s better to confirm it with the mobile operator. As a workaround, you can insert a SIM card into the mobile phone and share the internet via a hotspot.

But this shouldn’t result in the device rebooting. Can you trigger this behavior once more and generate a Full System report? Since this report contains sensitive information, you can send this information privately to support@emlid.com.

Thank you very much for the suggestions!
I’m on leave next week, so I’ll pick this up the week after and try alternative internet connection options.

I will send over the system report in a few minutes.
Thank you!

1 Like

Gareth,

I got your email. I’ll take a look at it and answer you once I have any updates. Have a nice break!

Thank you so much.
Likewise, I’ll report back with the results of the internet connection experiments.

Chat again soon.

1 Like