Unstable Bluetooth connection

Hi dmitriy, @igor.vereninov

Can you help me?.

Today I had several problems when I was doing stakeout with the Reach RS antennas and the mobile app Topographer Pro (lefebure app). From version 2.11 I noticed that the reach rs> lefebure-mobile topographer connection was not stable as in previous versions.

Could you confirm if the latest version of lefebure app (2018.09.07) works correctly with reachview 2.14, also if the Bluetooth works without problems ?, I had to press several times “connect Bluetooth” between my antenna and my cell phone.

The problems that I had; Unstable Bluetooth connection, rover-Android phone. Intermittent messages in reachview app, send error 32 followed by send error 111, connected to localhost.
In lefebure app option to “connect” although it indicates that you are using 10-12 satellites.
In reachview app; Age of differential Negative, loss of vision of the gray bars (base) and green-orange bars (rover), baseline frozen several times, all in fix.

The configuration of my antennas:

Base mode>LoRa
Glonass ar>off

Kinematic-fix and hold
Glonass ar-off
Correction input>LoRa
Corrections output>BT-NMEA
Bluetooth-On> connected android phone.


Is this still an issue?
I cant say i have seen similar problem.
Do you have multiple bluetooth enabled on rover/base? or other units interfering with phone signals?
I usually have all other settings not in use , disabled.

Hi Tore.
Yes, I tried it at home using ntrip (rtk2go) and the Bluetooth connection was still unstable.
I only enable the Bluetooth of my rover antenna and that of my android cell phone.
I had already done several times stake out following the steps of your video on YouTube and so far fails in that way. It may be the recent version of lefebure ?, update it a few days ago (v2018.09.07).

But also it had never happened to me that the reachview app froze and the bars (base and rover) disappeared, the baseline was frozen at such a close distance and the age was negative. That’s why I asked you for help to reflashing my antennas.
By the way, thanks for the help.

I will try changing my antennas, Base to Rover and Rover to Base to know if the fault is in the Bluetooth of my rover antenna.

What do you recommmend me to do?.

Tried the same lefebure version but with Reachview 2.15.0 and RS, this worked fine. Used Single mode. Correction in some way shouldnt matter

You are using Reach or RS? Ref. this

I will try changing my antennas

I have two RS.
I was referring to my base antenna to use it how to rover and my rover antenna to use it as a base. To see if the problem is in my enabled antenna how to rover.

You would recommend me to update them to the dev version. 2.15 …?

he was just stating which version he is on. But that is a DEV version, not a verified STABLE version, YET…so I don’t think anyone would really “recommend” that … “YET”.

But it’s up to you and your needs…if you updated to DEV version, and it didn’t work out for you, you could always REFLASH back to STABLE version if your willing to go thorugh that…not difficult, but may open up another can of worms if it doesn’t work straightforward as you’d like.

Tried a different unit running 2.13.2 which also worked fine.

Yes, try both units and see if you get the same error. Also try just in single mode with all other correction service turned off.
And dont update Reachview just yet.

@TB_RTK all the following I did inside my house.
The Bluetooth connection (NMEA) between my rover antenna and the lefebure app worked without any problem for more than an hour.

Apparently the problem arises when on the android phone change from lefebure to mobile topographer.
The NMEA connection is lost and becomes unstable.

Take some screenshots.

Look at the time when switching between lefebure and mobile topo … in reachview the connection was lost, in the Bluetooth window the word “connected” disappears under the paired device.

Everything I did in single mode.




“connected” disappears when on my Android phone this mobile topographer.

Hi Tim.

At the moment I’m with the stable version (2.14).
Apparently the problem is when my Android phone changes from lefebure app to mobile topographer, the bluetooth connection is lost and becomes unstable.

Can you maybe try another app to see if you lose bluetooth connectivity? I.e. Mapit GIS? There are MANY apps you can try… AutoCad, RTNFriend, RTKGPS+, Measurer, etc etc.

Can you try TCP/IP?

Also, in Lefebure is Bluetooth Connection Method = Secure via Reflection.
Auto-Enable Bluetooth unchecked?

I’m having same kind of problem. The Bluetooth connection on my OP6 becomes unstable but on my Lenovo Tab 4 8 plus it work flawlessly. Using Mapit GIS

I always do it that way.

Can you give me the steps / settings to establish the connection reach rs- mapit gis ?.

Hi Jaakko.

To establish the reach rs-mapit gis connection, you need a third app?, how to lefebure or the connection is direct?.

Could you tell me the steps to establish the connection ?.

No need for third party app. Direct connection from Oneplus 6 to Reach. Every time I open Mapit the Bluetooth connection becomes unstable. Bluetooth connection works perfectly when I use Lenovo Tab.

Maybe the problem lies in the Oneplus 6 / ZTE Blade A511 phone itself or the settings in the phone since works fine on other devices and for others?

Erro, maybe pickup a cheap android tabloid that is returnable and try that?

Hey there,

I’ve tested the Bluetooth connection with Lefebure app and can approve that this app latest version should work with Reach without any problem.

When Reach is connected to your Android device, you see the symbol marked with red on the attached screenshot. So please make sure it’s connected successfully before starting to work with the app.

Hi Tatiana, thanks.

Yes, the problem (I do not know if it’s because of my ZTE android phone) is when I change from lefebure app to mobile topographer, that’s when the connection is lost or becomes unstable.
I repeat, I do not know if it’s the brand or version of my phone, I have not been able to check with other Android phones.

Could you please check if on your galaxy tablet when switching from lefebure to mobile topographer the BT (NMEA) connection remains without problems?

Hi @erro.alfaro88,

How is it going? Do you still have the issue with BT connection?

I tested it with Mobile Topographer, as you asked. There were no issues with BT connection when I switched from Lefebure app to Mobile topographer.

I also checked it on Redmi Note 4, and it worked too.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.