Unresponsive Lumenier 12a ESC (SimonK AutoShot) Calibration

This is my first build and am running into snags trying to perform calibration of the ESCs. I’m using four Lumenier 12a (SimonK AutoShot) ESCs (see: http://www.getfpv.com/lumenier-12a-esc-w-simonk-autoshot-2-4s-n-fet.html). According to that details page for the ESCs:

The Simonk AutoShot firmware is pre-calibrated with endpoints 1060us - 1860us.

Not sure if they’re suggesting that calibration isn’t necessary? (Which doesn’t sound right to me.)

When I throttle up and turn on power, the LED flashes as expected (multicolored fast rotation) and I hear a steady and periodic “beep”. When I pull the power and plug in again, I hear the same beep pattern and the LED does the same thing. From the videos I’ve seen, I thought upon plugging in the second time, I should hear a different beep pattern indicating that I should move throttle back down to zero. Then hear another beep pattern, toggle the power, and be good to go.

Does anyone have any ideas on things I can try? What information would be helpful to troubleshoot this further? I’m thinking I’ll make a video this weekend and post that here as well.

Thanks for any input!

Take care,


Hey all, I just posted a video on my build which should give a little more context: https://www.youtube.com/watch?v=NS3kTKlxAbk. If anyone knowns next steps for troubleshooting my ESCs I would really appreciate the help!

As I understand it, my next step is really to try a radio transmitter to directly calibrate an ESC (outside of the Navio2 / Pi3 setup). Again, since this is my first build, I’d appreciate any help or suggestions!

Take care,


Getting a little bit closer to lift off. So I used the Navio2 servo example to validate the ESCs. Finally I have a way to troubleshoot this more. :slight_smile: The next (related) snag I’m running into is this: Channel 0 initially worked for a bit then stopped. When I tried channel 1, it worked (like 2 and 3) but also seems to turn on channel 0. Probably bad connection somewhere? Soldering issue? Check out: https://www.youtube.com/watch?v=7Sc4LjmbmQw

Anyone have any thoughts? I’m tracing through the connections now.

Things looking good now! https://youtu.be/qS7PYgn6H2M

(I think the earlier issue I was having was due to my test changes to the Servo example.)


1 Like

Looks good now! What was the problem after all? :slight_smile:

Really it was a mixture of two things. The first was that I expected that I needed to calibrate the ESCs. It turns out that the Lumenier 12a (SimonK AutoShot) ESCs are, in fact, already calibrated with endpoints 1060us - 1860us so the calibration step is not necessary. The second was that I expected ArduQuad to send a signal to the ESCs as soon as I made it through the “RC Not Calibrated” pre-arm check (it seems, anyways, that I need to make it through ALL pre-arm checks before it’ll actually send a signal to the ESCs).