Unable to use SiK radio after upgrade to latest image

After upgrading to the latest image - emlid-raspbian-20180525.img - telemetry via 3DR radios no longer works.

  1. Communication between the radios is fine. In Mission Planner both local and remote radios are visible and commands can be sent between the two.
  2. Swapping out radios does not fix the issue.
  3. Tested on two separate RPi3 and Navio2 combos.
  4. /dev/ttyAMA0 is present
  5. Switching the radio to a USB port works.

emlidtool info

Vendor: Emlid Limited
Product: Navio 2
Issue: Emlid 2018-05-25 bbc8647b0ebcef1af95090b9a5aaf59cc78aee97
Kernel: 4.14.34-emlid-v7+





Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)



Possibly relevant log messages:

Jun 8 11:09:48 tarot1 kernel: [ 0.350777] uart-pl011 3f201000.serial: could not find pctldev for node /soc/gpio@7e200000/uart0_pins, deferring probe
Jun 8 11:09:48 tarot1 kernel: [ 1.151115] uart-pl011 3f201000.serial: cts_event_workaround enabled
Jun 8 11:09:49 tarot1 kernel: [ 8.475869] uart-pl011 3f201000.serial: no DMA platform data

Trying to talk to /dev/ttyAMA0 with
miniterm.py /dev/ttyAMA0 57600

does not interrupt the stream of chars on the screen. The radio enters command mode after +++ if the connection is made via /dev/ttyUSB0

Thanks for report. We’ll look into it as soon as possible.

1 Like


Have you enabled Serial using raspi-config?
enable_uart=1 shouldn’t be in /boot/config.txt.

Hi Alexey,
Apologies for not replying sooner. I ran into trouble with the telemetry interfering with GPS reception. I’ve had to temporarily stop using it until I get some time to debug this. Instead of the serial interface on the Navio2 I was using one of the USB ports on the Pi.

However, my understanding on the RPI3 is that in order to have serial enabled and to use the PL011 hardware enable_uart=1 must be set. Please could you clarify.

Many thanks,

Hi, Rodger,
Yes, you’re absolutely right. To enable PL011 (GPIO 14 and GPIO 15 UART pins) you should set enable_uart to 1.
There is also pi3-disable-bt overlay should be present to disable the Bluetooth device and restore UART0 to GPIOs 14 and 15

1 Like


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.