Unable to upload while cross compiling (px4)(navio2)

make emlid_navio2_cross upload
[0/1] uploading px4
ssh: Could not resolve hostname : Name or service not known
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: unexplained error (code 255) at io.c(235) [sender=3.1.2]
FAILED: boards/emlid/navio2/CMakeFiles/upload
cd /home/john/Documents/Test1/Firmware/build/emlid_navio2_cross/boards/emlid/navio2 && rsync -arh --progress /home/john/Documents/Test1/Firmware/build/emlid_navio2_cross /home/john/Documents/Test1/Firmware/posix-configs/rpi/*.config /home/john/Documents/Test1/Firmware/ROMFS pi@"":/home/pi
ninja: build stopped: subcommand failed.
Makefile:193: recipe for target ‘emlid_navio2_cross’ failed
make: *** [emlid_navio2_cross] Error 1

I keep getting this error whenever i run: make emlid_navio2_cross upload
I’ve tried
export AUTOPILOT_HOST=pi@x.x.x.x
But still i keep getting that error
Can please help me with this.

Hi @gammerboy,

I’m afraid we don’t officially support PX4 firmware for Navio2. I’d recommend reaching out to PX4 github/forum with this issue.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.