Unable to reflash

I am having a difficult time setting up my Reach RTK unit. I started setting up the wifi just fine and was able to find the IP with fing, but I keep getting an LED flash white-blue-blue-red.

Other topics in this forum had this error and solved it by reflashing but I keep the intel flash tool is unable to find my device and won’t let me reflash the system.

Im using a windows OS

I can’t get the intel configuration tool to register that the board is even plugged in

I dont know how to use cli to reflash and can’t find a good set of intructions.

When i plug the board in and connect to its hotspot im able to reach v1.2 of reachimage
I’ve tried going into settings and clicking the wifi button and upgrading firmware that way but I get an error message after it runs for 10 minutes

what am i doing wrong?

Hi, please flash v2.3, we do not support v1.2 any more.
https://docs.emlid.com/reach/common/reachview/firmware-reflashing/

I am trying to flash v2.3 following those instructions but I can’t get it to work
I download the drivers, configuration too, and reachimagev2.3
When I get to the third picture it just sits for several minutes without registering the device.


Why do you stop here ? Read troubleshooting tips > get the two files, open a console window and it works.

In your first picture, click repair drivers. Let it finish. Then try again, but have reach unlugged to you get to picture 3 and
then plug it in.

Still nothing.

I’ve tried repairing the drivers and continuing to use the intel configuration tool.
I also tried using the platform flash tool lite.
When I try opening a command window and running flashall.bat it looks like this and I plug in my board when it tells me

After about a minute command window disappears and the board hasn’t reflashed.

I think the board is somehow not connecting to the computer. I’ve tried it on 2 laptops and a desktop. I’ve tried it connected to the reach hot spot and not connected. I can’t get it to connect to a network and I was hoping reflashing the firmware would help that but that’s not possible if I can’t reflash in the first place.

Are you using the original USB cable with PISEN logo on it?

If not, perhaps the cable you are using is designed for charging only (no data)?

In the directory with the v2.3 files I have the two files ‘dfu-util.exe’ and ‘libusb-1.0.dll’.
With the reach connected via USB I type flashall ‘Enter’ in the command window. The screen shows ‘Please plug and reboot the board’ and I unplug the reach for a second and plug it in again and it worked for me all the time…
After the flashing (it says wait 2 minutes) I power cycle the reach again …

I don’t know what was wrong I was using the USB with the PISEN logo.

I ended up following all the same steps on a friends computer (another PC running windows 10) and it worked on his but not on mine.

Still no clue what was wrong.

same problem here. Reach RS units.

My ROVER shows error in Device Manager (yellow triangle symbol with exclamation point) next to Intel Edison USB RNDIS Device. SHOWS COM PORT 6.

My BASE when plugged in doesn’t have this yellow symbol error, but then again it doesn’t even show Intel Edison USB RNDIS Device either nor the COM PORT 6 as if nothing even registered after installing the Edison Driver from the Firmware Reflashing instructions. I noticed when Windows 10 was trying to connect the device after powering up BASE device came up called “Merrifield” and went away?

EDIT:
Well, monkeyed around, TURNED OFF REACH RS, plugged in USB, EDIT: POWERED ON IMMEDIATLEY AFTER, then waited and it seemed to work on it’s own. Before, I had it POWERED ON when plugging in USB before and the CMD screen would close out after a minute or so each time failing.

Screwy indeed… then also take note that the “PLUS” (non-Edison?) versions require different method altogether.

https://docs.emlid.com/reachrs/common/reachview/firmware-reflashing/