Unable to receive data from the Reach TTL UART

My goal is to subscribe to NMEA output through the TTL UART on the Reach.
I set the configuration for solution 1 output as follows:

I’m using a 3.3V TTL to USB cable and attempting to read the output through RealTerm with the display setting on ASCII:

Also, here is the software/firmware versions I’m working with:

Things I’ve tried:

  • Changing baud rate multiple times. I know this change is being applied while viewing the output with an oscilloscope.
  • Tested the cable with another TTL UART device with 3.3V logic. The cable checks out.
  • Changed the base station module to a rover configuration with the same settings. The results are the same.
  • Set up the base station on a roof mounted on a tripod and drove a robot around with the rover station attached. Everything seems to work here as I was able to see the Satellites with their corresponding SNR levels in ReachView. Also, I was able to successfully map out the rover’s course with RTKPlot.
  • Tried different output formats other than NMEA. No luck.
  • Tried setting the output to solution 2 with the same results.

Any help is much appreciated. I feel like I’m missing something simple since it’s happening on both modules.

set stop bits to “2 bits”
i’m really just trying to help until emlid has time - so don’t expect me to be helpful:

Thanks for the response. I set the stop bits to 2 with no change in results. I did find something interesting though. When I turn the solution 1 and solution 2 output off in ReachVeiw, I still receive the same “trash” output…Not sure what this means. It happens on both modules.

Performed a screen on the Intel Edison ttyMFD2 serial port.

Confirmed the baud rate was set at 57600:
stty -F /dev/ttyMFD2 -a

screen /dev/ttyMFD2 57600

Nothing showed up on the output. I updated the ReachView app and got the same result.

I’m able to set up solution 1 as a TCP client and output nmea data to a server. However, I need to get the serial output working for my application…

I am having a very similar problem. Ben, did you find a solution? Thanks much!