Unable to locate package apm navio2

What do I need to do to fix this? I need the latest version of APM.

Are you sure you are using the emlid raspbian image? I can’t see apt checking the emlid repository.

You’re using an extremely old image! Please flash SD card once more with a more fresh one. The image with the hostname navio-rpi has been deprecated for a long time. Sorry, if you haven’t heard of it!

Could you give me some help as well? I can update the pi but it does not allow me to download ardupilot.

Do you know why?


ArduPilot has been part of our Emlid Raspbian for more than a year. Please, refer to the docs for how to setup everything.

I have followed the same step as what it says, still no success. Do I have to install the telemetry? As I do not have one yet.

Also, I did all the steps as it says, but when I reboot, the same welcome page appears again. What I have done wrong?

Thanks for your help

To transmit telemetry over WiFi you have to setup your GCS’ IP address in /etc/default/arducopter. Just simply set TELEM1="-A udp:<your ip address>:14550".

Hi Koby,
I did as described in the docs. I changed the IP address to my laptop address. Do you know what else is wrong?

Did you reload config and restart ArduPilot?

Yes, I did. When I type in start arduplane, the annoying thing is nothing happened. Is it supposed to be like that? How do I know if I have done correctly? No messages at all.

You don’t get any messages after successful start of arduplane. To make sure that it functions normally, type systemctl status arduplane. You should see Active: active (running).

I tried. Do they look correct to?
When I open mission planner, the plug is still red color. Any advice? Thanks

What is the output of ifconfig?


Hi Koby,

I think it is working now. Thank god. I played with mission planner. it is connecting now. cheers