Unable to get telemetry radio to connect

Help! I’m confused lol.

Setup
Latest mission planer
Both base and rover all talk to each other.
Latest reach update.
Reach base in AP mode or with USB Conection to laptop.
Telemetry radio 3DR v2 (cable modified as per docs) and connected to reach base unit.
Sik settings for both ground and air end changed as per docs.
Pixhawk running ERB firmware.

I just cannot get the base radio to connect to the air end. I’ve tried usb to reach then picking the com port In MP and I’ve tried connecting to the reach base via tcp, I know the ip of the base unit but unclear on the port number but neither method works. I’m going to assume that a reach unit connected via usb and the 3DR radio should connect? Or must it be via AP.

3DR radios connect fine (in sik mavlink mode) if reach base is omitted. But nothing in sik RawData mode

What am I missing?

All the best
Andrew

3DR radio should be connected to the laptop running MP, not to the base Reach.

1 Like

Thank you

I have been trying to connect this way with Reach RS and M+. So if my 3DR radios are connected to the M+(Air radio) and laptop (ground radio) running Mission Planner then how do I connect Reach RS? I know I can connect it to the laptop via wifi and use the IP address in a browser, but does the Reach RS need to be connected directly to Mission Planner? I ask because I have not seen a way to connect it to MP.

Hey Troy,

Great to see you on forum!

Here is the explanation on how to connect base station and Mission Planner:
https://docs.emlid.com/reachm-plus/ardupilot-integration/#base-setup

Great, Thank you Dmitriy. I have looked all over for a solution but did not consider looking at MP as an option. It did not occur to me. Very helpful

1 Like