Unable to flash reachview v2, please

Hello Everybody, (and sorry for my poor english)

i’ve tried to flash (unsing new reachview v2.1) one of my reach using the Terminal Guide (https://docs.emlid.com/reach/firmware-reflashing/)
but now, it’s not recognized and is not working anymore.
Connected to the computer, it takes a blue+red steady light, then a yellow flashing light and stay on a flashing green/blue+red light
I’ve tried many usb cables, many usb port.

Now, using the GUI, this is what i get :

The Edison is not identified by the GUI.

I’ve tried the Terminal guide. I’ve unzipped the files in C:, but when starting (as admin) flashall.bat, it’s saying access denied (via CMD.EXE) .
what else can i do ?
Thanks for reading me .


Have you tried flashing the updated 2.1 image?

I have been having the same problem too. Flashing the v1.2 image is no problem with either the Intel utility or the flashall.bat, however I really have problems with the beta image. Here is what I do:

I download the image from your official link, unpack it and unzip dfu-util in the image folder. I start flashall.bat, then according to instructions plug in and reboot the reach and the flashing procedure completes successfully.
However, after that just like the original poster, the Reach unit is not recognized by the Intel utility, also it says the disk is not formatted. The Reach unit creates its hotspot, I connect to it, no problems. However, then I try to access it through Chrome on Pc and chrome on Android and it is not there. I try http://reach.local:5000 and also, but it really is not there.
I am using the stock usb cable and a USB2 port on a standalone PC with Windows 7, all Edison drivers installed.

After these I can revert to the V1.2 image, no problems. I read some forum posts, but I can’t get any more information. Could you advice on what to try?

@toncho, v2 doesn’t require port 5000.
You need to go to http://reach.local or

1 Like

Thanks a lot - you solved my problem. Without the port 5000 I accessed the device and set it up and it is working now.

1 Like

Thank you for your responses.

it worked… i’m connected whith my reach again…
My fault : i’ve missed the “after flashing” instructions, and forget to connect to the hotspot.
So now, i’ve reachview 2.1 on the rover.

I’m gonna continue tomorrow…(flashing the base)
Thanks a lot. Vincent