UNABLE to fix gps after connecting gps antenna purchased from navio store

i followed the instructions stated in the emild documentation on the hardware setup. after doing the compass calibration as shown in the pictures below the mission planner shows a gps no fix sign. please help thanks !!! i went to an open field and when checking the temp file it shows gps pass

15

No Fix say a GPS is detected, but position is not.

As GPS chip is on the Navio2, even without good GPS signal, the No Fix msg is the minimum.

You have to check the seating of the GPS antenna plug:

Before changing any setting, there is screen showing the health of GPS,

GPS status is 1 (present but no fix), satcount =0… It is a normal state just after boot. Depending of the date of the last GPS fix, you may have to wait some time before everything is updated in the GPS memory. Clear sky view is needed. You can also move your GPS antenna away from Navio to be sure there is no EMI interference.

3D Fix msg appear when 4 sat are detected. Horizontal position could be away (far) of your real position. When hdop drop below 2, position is better.

Now, GPS status is 3, there are 12 sats and hdop is 0,77.

Here are my settings. Default may work… If your problem is not solved, you can have a try at them.

GPS_GNSS_MODE set at 67 is GPS + GLONASS + SBAS

2 Likes

hi what do you mean by the date of the last GPS fix. and i have also tried to configure in the mission planner according to your settings in open field but the gps still states no fix is there another way to go by it

in addition i also tried the navio gps driver installation shown below but it still shows no gps fix


i have also connect an external gps with compass. Is it right to add in GPS2 ="-E /dev/ttyAMA0"

or should i try to include an RF filter to block it as seen below. an if so what are some things i can use as an RF filter

this is how the connection of the externally connected gps connected to the uart port and 12c port looks like as i still am unable to connect to gps it stills say not fix

Try to avoid sharp bends in the antenna cable. Sharp/narrow bends might cause signal reflection inside the cable.
Try to add a groundplane under the antenna. I use plywood with aluminium tape or big metal lids of jars. The bigger, the better, but the copter should still be able to fly. 10cm diameter/side length should do.
Check if there is any dirt/dust in the antenna connector. Use dry air from a can to blow out both connectors. Do not use air from a compressor, it may contain oil vapor.
With everything running, push onto the antenna connector with your finger for a while and see if the GPS sees any sats.
The “date of the last GPS fix” means how long ago the GPS last had a lock/fix. The longer the time since the last lock, the longer it takes to aquire one.

1 Like

Do you have any updates, @reynard?
Did you try any tips from @mlebret and @schuermannsebastian messages?

hi i have connected an external gps to use it to get a gps fix on mission planner. however the internal compass with the gps antenna does not seem to be working. may you show me the configurations setting in maybe sudo nano /etc/default/arducopter or mission to show how you did it with the internal compass to get a 3d fix on mission planner to do autonomous missions.

Hello,

There are a few steps to follow. I will help you with how I proceed with external GPS connected to UART and i2C compass connected to i2C (Navio2).

10

My External GPS is M8N and compass is supported by Navio2 software
(LSM9DS1, AK8963, AHMC5843)

GPS settings:

In the full parameter list, you have to set GPS_TYPE2 to Auto (1) or UBlox (2). Then set Autoswitch (No, best or blend).

In full parameter list you have also to set Serial 4 (Switch -E in arducopter) at 38400 and GPS

11

/etc/default/arducopter is edited to set the external GPS

TELEM1="-A udp:192.168.1.37:14550"
TELEM2="-E /dev/ttyAMA0"

Options to pass to ArduPilot

ARDUPILOT_OPTS="$TELEM1 $TELEM2"

Now you can reboot your Navio and check the 2 GPS are identified:

59

For compass, after calibration, you choose compass 3 (external) as primary compass.

11
what this does is to activate the internal gps witht the external gps right?? if so do i need to add the gps antenna from navio shop

If you want to only use an external GPS, you can. To use Internal GPS or both Int and Ext you need to plug an antenna. Emlid is a good one (amplified) at low price.

Some settings could be changed to use only the external one:

GPS_TYPE is set to 0 (none)

16

GPS_AUTO_SWITCH is set to 1 (Use best). If set to 0 (Disabled) moving map in mission planner is not receiving position data (???).

02

RMK: GPS status in moving map display (nSat, hdop) stay at zero.
GPS time is also missing (not updated)… in status screen

If you set Telem2 flag to -B (main GPS), external GPS is identified as GPS 1 and all data (nsat, hdop, GPS time) is displayed.

33

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.