Unable to Cunnect Reach RS2 to Hydromagic

I am unable to read Reash RS2 from Hydromagic Sorfware. I ran zadig to install the drivers and this was successful. It registers Reach RS2 as a Universal Serial Bus Device (in device manager) However, I’m not sure if it is transferring data; Hydromagic is definelty not able to read the device. Please help!

Hi Narendra,

Welcome to our community forum :slightly_smiling_face:

I’ve tested the connection between Reach RS2 and Hydromagic Software and everything works fine. Let me describe the workflow I’ve used:

  • configure the position output on the Reach RS2 (check the screenshot)

  • then connect Reach RS2 to the PC over the USB cable, check the “Device manager” - the Reach device will appear in the COM Ports tab

  • in the Hydromagic Software select “Preferences” and add a new device, the configurations are shown on the screenshot below. There you should use the COM Port number from “Device Manager” and the serial speed configured in ReachView

  • after saving the configurations, you can open the “Monitor” tab and observe the NMEA data stream

Please note, the NMEA data will be transmitted if the unit has a solution status.


Thank you for your response.

Unfortunately this not work because I do not have Reach RS2 on a COM port.

I have downloaded and run Zadig and in my device manager it is now registered as a “USB serial bus device”

I think this is the issue. I do not know how to get it as a COM port. Can you please advise.

I got through. I uninstalled the driver and then reinstalled it. Works now. Thanks.

1 Like

Thanks for the update on this!