Unable to control servos with Navio2


i’ve just started playing with the navio2 and it’s great!

It works over wifi, the raspi camera streams with gstreamer perfectly.

Unfortunately, i am unable to get any servo control working. I have BEC 6v into the servo bus, but none of the servos are responding.

i have armed it an placed it into stabilize, and even tried do_set_servo commands within mission planner. No luck. Has anyone else experienced this?

any help would be greatly appreciated!

Are you running Arducopter, rover or plane?
Arducopter has no servo outputs configured by default and servos on the motor outputs will not move until you completed the whole setup/calibration and will probably get damaged due to the high pwm frequency on the motor outputs.
Arduplane has the first four outputs configured, one as a motor output and 3 as servo outputs. If you did not change anything, it should be: output 1: aileron, 2: elevator, 3: throttle and 4: rudder.

Hi Sebastian,

i’m using plane.

I have completed the calibration (with the exception of RC)

i have tried connecting various servos in various ports. When i first connect the battery, they move a little bit…but appear to have no signal.

Finally figured it out. I’m a little embarrassed to post this, but hopefully it helps other people that may have the same issue.

I had kept the default arduplane config, which was for navio+. I needed to update it for option 3, navio2.

Screen shot below, thanks for the help.

1 Like