Emlid

Community Forum

Unable to connect to Emlid Edge ssh


(Patrick Duhaime) #1

Hello,

I am trying to login to my Emlid Edge to configure the network so it stop switching to hotspot at reboot, I want it as a wifi client,

On this page: https://docs.emlid.com/edge/dev/ardupilot/, it says:

Perform an SSH connection to your edge with

$ ssh pi@edge.local

Tip
The default ssh login is `pi` , password is `raspberry` .

weedee01@weedee01:~$ ssh pi@edge.local
The authenticity of host ‘edge.local (10.5.5.100)’ can’t be established.
ECDSA key fingerprint is SHA256:W8mqZ8V5Bfb75LohIoP0LYqHDLVirrG+b96wCt1rsUM.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added ‘edge.local’ (ECDSA) to the list of known hosts.
pi@edge.local’s password:
Permission denied, please try again.
pi@edge.local’s password:
Permission denied, please try again.
pi@edge.local’s password:
Permission denied (publickey,password).
weedee01@weedee01:~$ ssh pi@edge.local
pi@edge.local’s password:
Permission denied, please try again.
pi@edge.local’s password:


(Patrick Duhaime) #2

Bad typo sorry… you can mark this thread as resolved


(Marc Lebret) #3

Hello,

My Edge is configured as Hotspot, and ssh login is ok, both with ssh pi@192.168.0.1 or pi@edge.local with raspberry as password.

I have the same (not the same data) ECDSA alert,

Marc

I had this idea also…


(Patrick Duhaime) #4

Hello again,

As I am not very familiar with network configuration on the Emlid Edge or the raspberries in large, can someone point me what are the steps to disable Edge hotspot and configure so that Wifi will be in client mode at boot ?

Thank you


(Marc Lebret) #5

https://docs.emlid.com/edge/qgc/wifi-setup/

Edge wiki is very helpful.

Marc


(Patrick Duhaime) #6

Unfortunately it is not for this problem, because the problem occur exactly after following this guide :smiley:

Yes you will be able to switch between networks once you have configured a network and saved it, but at reboot your EDGE will be back on Hotspot. What I am asking is how to disable hotspot config to use my EDGE as a wifi client at boot.

I am using the edge as a rover, there is a router and a PC on the rover, the PC sends Mavlink commands base upon video capture to ajust speed, now every time the EDGE reboot I have to connect to the edge hotspot, browse to the wifi setting page, click on the switch button, reconnect to the router on the rover… I would like not to do that + the fact that I can loose comm at any point and the hotspot will come up, resulting in loosing comm between the PC and the EDGE…


(Patrick Duhaime) #8

Ok I was able to configure network by editing the

/etc/network/interfaces

#interfaces(5) file used by ifup(8) and ifdown(8)

Please note that this file is written to be used with dhcpcd
#For static IP, consult /etc/dhcpcd.conf and ‘man dhcpcd.conf’

#Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

and the /etc/wpa_supplicant/wpa_supplicant.conf is updateted with the config to connect to my network

The problem that I see with this is the can0 interface is now disabled and the wifi led is not working anymore, but, evreything else works as I wanted… I am pretty sure there is a better way to do this, I am open to any advice on this.

thank you !


(Tatiana Andreeva) #9

Hi @patrickduhaime,

This workaround should help:

  1. connect Edge to the network using the guide Mark shared above
  2. ssh to Edge
  3. open /etc/wmd/main.conf file
  4. replace autoconnect = ap to autoconnect = client

(Patrick Duhaime) #11

Thank you very much Tatiana !