Unable to connect RS3 to android phone unless on home network

Hello all, sadly my first post is to ask for help with my new rs3.
I followed the set up instructions and was able to connect my rs3 to my home wifi, and also to my android phone so that I could use the Emlid Flow app. I updated to the latest firmware. So all good, if the phone and rs3 are on the home wifi.

The problem I have is trying to connect the rs3 to my phone’s hotspot. As I won’t be at home whenI use the rs3, I want to connect to my phone and use mobile data to stream ntrip corrections.

However, as per the online instructions, I turn off mobile data and battery care on the phone, so that I can connect to the rs3 hotspot. The receiver doesn’t even show in the emlidflow app! So I can’t select it to connect to it.
The ONLY time I can connect is when the phone is on the home wifi.

I have been able to set up my phone as a wifi option in Emlid Flow. I thought that if I deleted the home wifi option from the app, I would be able to force the phone connection. BUT there’s no option to do that either!

What am I doing wrong? Surely it’s not a difficult thing to do? Please help before I lob this thing into a tree. Thank you!

I had the same issue with my M2’s/RS2 when I got them;
If you don’t have a sim card in the RS2, delete(forget) all other wifi networks in the field on the phone/tablet. Turn on hotspot on your phone/tablet first (make sure the receiver hasn’t been turned on yet).

As soon as the hotspot has been created, turn on the receiver. It should be listed as a device to pair with).

My M2/RS2 connects well first time from when it finally worked… It’ll do the same when you get back in your home wifi.

1 Like

Hi, thanks for replying.
I don’t want the phone to forget my home networks but I have ensured it can’t connect by switching off the home router. I was then able to delete the home network from the Emlid Flow app, so just leaving my phone as a hotspot wifi point. I could then connect the rs3 and the phone.
I then went out into a field where the only signal is mobile data.
However! The connection is the wrong way round; phone has connected to the rs3, not the rs3 connecting to the phone. This means that ntrip signals can’t be picked up as the rs3 has no wifi, even though the phone has good signal. I tried bluetooth on and off, no difference.
At a loss now, this is just an expensive, useless to me item.

Hi, I’m using an RS2, so this might not apply. I had to turn off W-FI on my phone (Samsung S22 Ultra) in order for the RS2 to see my phone hotspot. I was then able to connect to the RS2 via the phone hotspot and also was able to receive NTRIP service corrections from SmartNet. I also checked the phone and I do have Mobile Data enabled. The network LED on the RS2 is blinking between white and blue, with the blue LED remaining solid for about 2 secs and then repeats switching back and forth between white and blue LED’s. This was at my home where it normally connects automatically to my home router, but I placed my phone in hotspot mode and connected through the Flow app to the hotspot. I should be receiving an RS3 in about 2 weeks, so I’m hoping they have the tilt feature working fully in FGA.

1 Like

Hi, thanks for the reply.
I don’t know what I did, but after flicking wifi off then on, setting internet to mobile data, ensuring phone hotspot was on, and then booting up the rs3, it connected to my phone hotspot straight away and started receiving ntrip corrections!

Thanks again for helping, I think the issue is now resolved :blush:


Hi Jubba,

Apologies for the delay.

I’m glad the connection issue has been resolved. If you encounter the same issue in the future, please feel free to email us at support@emlid.com. We might ask you to send the full system report so we can understand what’s going on with the device.