Emlid

Community Forum

Unable to change MNT_TYPE for a gimbal


(Fredrik Falkman) #1

Hej!

Trying to get a servo gimbal working on a Navio 2.

When I try to set “Gimbal Settings: Type” or “MNT_TYPE” I get the message “Change of parameter MNT_TYPE requires a Vehicle reboot to take effect.”

But no matter if I reboot from QGC or if I make a full reboot, the setting doesn’t take effect.

Running the latest Emlid Arduplane 3.9.5 and trying this from the latest QGroundControl.

Happy for any suggestions!


(Gleb Gira) #3

Hi @fredrikfalkman,

I tried to reproduce your issue but unsuccessfully. What parameter in ‘Gimbal Settings: Type’ are you trying to set?

Can you please share photos of your hardware setup on Navio2, how do you connect servo gimbal?

Also, some step-by-step screenshots of reproducing the issue would be helpful.


(Fredrik Falkman) #4

Thank you for the reply!
Away from my computer so can’t do screenshots etc right now but trying to set “MNT_TYPE” to “servo”. Also tried some of the other available settings bu with no change.
I have connected two small standard servos to act as roll and tilt axis to pwm-pins 13 and 14 on the navio2.
Hope this clarifies things!


(Gleb Gira) #5

Hi @fredrikfalkman,

I wanted to check if you resolved the issue? If it still occurs, try to connect servos to the pins 1 and 2. I also still need photos of the hardware setup.

Waiting forward for your response.


(Fredrik Falkman) #6

Hej!

It was a problem with the latest QGround Control that wouldn’t save parameter changes. Resolved in daily builds.

Thanks!