Unable to arm Navio 2

I have fully built drone.
Completed calibrations of accel, compass, controller, esc’s, motors run at end of Esc test with throttle.
Have tried to arm with and without failsafes.
Will not arm, no messages or displayed reason in the GCS window.
Just says disarmed.
Doing the standard min throttle and right for more than 5 and less than 15 seconds.
No message, no arming.
ANY help would be really welcome here, I have started over several times from image up through the full GCS testing. Turning all the failsafes off and one by one.
Thank you if you have ANY advice for me.

Question, Is your radio calibrated?

Yes, multiple times, just to be sure.
Made the mistake of clicking on completed once. It actually re-runs the radio setup again.

I would think that the ESC testing would not work (revving the engines up) if my radio was not calibrated.
Also based on other posts here, I upgraded to the 5/25 image and reinstalled everything with the same results. (still wont arm and shows no reason why)

Last but not least, since the sticks cause no events, the switches change the modes of the fc as programmed. So the radio is calibrated.

Can you arm your copter with the GCS? Are you sure the stick/rc mapping is the same for your radio and ardupilot? So that the yaw stick really inputs yaw?

I have not tried to get the copter to arm from the GCS. I will borrow a good joystick and give that a try tomorrow. I am not sure how the mapping would be different from the radio to ardupilot. Isnt the fact that I could run the motors using the left stick throttle in the esc calibration on the Mission Planner show that the mapping is the same?

You do not need a joystick just to test arming. Every GCS I know has a GUI item (clickable button, slider…) to arm/disarm the vehicle. Just remove the props and try to arm your copter.
Even if the left sticks up/down movement controls the throttle, it is still possible that left/right controls any other of the remaining three main channels. So throttle down and right might not result in yaw input. You can check if all sticks control the right bars in the radio calibration screen.

Thank you, it was a controller misconfiguration. I downloaded Q-control on my iphone. Armed the motors using the app and flying the drone immediately let me know the errors on my controller configuration. Thank goodness for loiter mode as I would have been blown into a wall before I figured out how the controller was working. Thank you for the suggestions and assistance. First drone built and flies!! :slightly_smiling_face:

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.