UDP Telelemetry

I configured the Raspberry Pi as an access point using an Edimax USB dongle. I can ssh into the Pi from a laptop without problems.

Will it be possible for MissionPlanner to receive telemetry data from the Navio+ using this WiFi access point via sudo ArduCopter-quad -A udp:[MP-MACHINE-IP-ADDRESS]:14550 ?

What about if I also want to use tablet? do I need to use -C for the table?

sudo ArduCopter-quad -A udp:[MP-MACHINE-IP-ADDRESS]:14550 -C udp:[TABLET-IP-ADDRESS]:14550

Yes, you definitely could.
It seems that the configuration may work, I have not tested the android planner yet but this could work indeed.

You may understand that connecting another device on the Wifi of your Drone access point reduce drastically the bandwith of your wifi and may reduce the general performance of the entire system, range, signal quality, speed etc… due to the architecture of the 802.11bgn protocol.

I recommend to use either a laptop or the tablet, not both in a Wifi configuration.


I agree. We’ll use either a laptop or the tablet, but not both in a Wifi configuration and it’ll be used for indoor tests only (short range).

However, I’m having trouble getting it to work. Some folks in the forum suggest to use -A udp: with the GCS IP address, others suggest A udp: with local host (, other suggests -C instead -A, and others suggest to use socat in conjunction with the previous.

I have tried all the above combinations and I’m still not be able to get a heartbeat in Mission Planner. Has anyone be able to get this working?

ArduCopter-quad > RPi2 > Edimax dongle (as an Access Point) <–> Laptop > Mission Planner (UDPCI)

I’ll definitely help you,

You need to use -A udp:ip-address:port to SEND telemetry to the specified address.
-A is the primary telemetry, so it will work with GCS MavLink compatible.

As you may understand udp is the transport method over IP, it means the Drone will send without controls the telemetry packets.
Therefore, you need to disable all FireWalls on your laptop and make your GCS listening on the specifiec port and do not use UDPCI but use UDP.
Also make sure that ICMP (Pings) are working between Drone and GCS.
Using -A udp: does not make any sense since the Drone will send telemetry in the loopback … Only usefull if you use MavProxy on the drone itself.

Hope it helps.

Wow, thank you! This indeed helped. It works now. Thanks again!