Udp connection fine tcp not?

Having problems connecting via tcp. Udp no problem and this would be fine other than not having the ease of a tcp auto conection available.
Also I’m unable to access the navio through the terminal in mission planner. “Can’t open socket error” i need to be able to change the minimum power delivered to the props as they stutter. I believe the only way to do this is via the terminal. I’ve looked into router settings and nothing seems amiss there.
Also interested to know if there is any direct wifi connection available eliminating the bed for a wifi router?

What exactly is the problem with the TCP connection? You need to be a bit more specific. The terminal function through the GCS is almost never used anymore, even on the MCU autopilots like APM2.x or Pixhawk. Most (all?) of the functionallity moved into the GUI part of Missionplanner.
It was never used with the Navio.
In what situation are your motors stuttering? After arming, while spinning idle?
You can always configure your RPi for an ad-hoc wifi connection. It should work with most wifi dongles and there are heaps of tutorials out there.

Thanks for the ad-hoc info. I’ll look into it.

Yes motors stuttering. They are set to turn on arming but some don’t quite make it at that idle state. Once throttle raised no problem even when returned to minimum throttle. I think due to arming/idle throttle being slightly lower than what it needs to be to start the motors see vid

As for tcp access. tcp: set in pi.
Enter the same value into mission planner gives an “unspecified address can’t be used” error. So i try tcp: (actual pi address) i get “cannot connect because target machine actively refused it error”.
If i try auto option and connect mission planner crashes no matter what the pi is set to.
Qgroundcontrol also won’t connect when tcp is used. But as with MP is fine using udp.

Just found a value in the full parameter list that changes the armed spin rate. MOT_SPIN_ARMED normal setting 70 now set to 80 and all props start.

You do not have to type tcp: in Missionplanner, just select TCP in the connection drop down list and enter the RPis IP address. Then the port in the next window.

Sure that’s how I’ve done it.

Update: esc’s weren’t calibrating nicely. I reflashed blheli latest version and instead of calibrating them in the usual way set the min values within blheli using an arduino. This seems to work perfectly and I don’t need to calibrate the esc’s anymore.
tcp: problem went away with a fresh raspbian and arducopter install. now no problems there.

No direct wifi yet as I’ve not found anything that’s specifically pi 3 and it’s built in wifi. I have found this script for a pi2 which I may give a go once I’ve backed up my current state. It seems a very easy solution if it works.


Here’s a direct d/l link to the script that installs it.