UART Parse Error and Unable to Calibrate 6 Ch Radio

While working on my Navio+/Rpi B+ Combination I am receiving the following error!

Also, If I somehow get the APM firmware to work, the APM Planner 2.0 for Mac receives information as coming from a 8ch receiver while I have a 6ch one with PPM output. At last if I try to calibrate the radio I get the same unable to calibrate thing.

sudo Arducopter-quad -A udp:

You were missing the “:” after “udp”.
Depending on the make and model of your RC RX, it may very well be possible that it puts out 8 channels through ppm, even if it has only 6 pwm servo connectors.

Thank you @schuermannsebastian. So, is there any work around this or should I use a PPM Encoder?

Which RX do you use?

This one -

It comes bundled with -

Yes, with this receiver you will have to use a ppm encoder.

Okay with " sudo ArduCopter-quad -A udp: " I am receiving the following problem.

PANIC: failed to take _spi_sem 100 times in a row, in AP_Compass_AK8963::_update


Try to reboot the RPi

Are you using our real-time Linux?

Yes, I am using the real time one. Although restarting the board solved the problem as of now, I could’nt understand why it occurred in the first place. I am still dealing with the TX Calibration though. :expressionless:

@Sarthak_Dubey I suggest an upgrade to RPi2, it will allow to run Copter main loop at a higher rate and is our main platform for development and testing.

Do you have a ppm encoder? Without it, you do not need to try anymore. Navio+ is ppm input only.

Got the TX working, Done with the configurations. Tried it with APM and Mission Planner on a windows machine. Apparently, The problem lies with Mac version of APM Planner. Also the AP_Compass_AK8963 problem was due to powering the Rpi B+ with a wall adapter (5V 2A), using a battery solved it (I guess because it did not occur again).

Q- How do I correct Inverted Pitch and Roll on Flight Display Panel?

Suggestion : Add a method to connect wifi to rpi using wpa_gui in lxsession, Quite easy rather than editing in nano or SD card.


The orientation should be correct by default. Front is where USB and Ethernet connectors are. Do you have Navio+ mounted that way?

Accel calibration was broken in the last release of APM Planner, but it is fixed now and if you pull latest build it works.

Accidental AK8963 startup failures had been fixed and merged in APM master, we hope to forget about them with the next release.