Uart & LoRa Radios will not work on M+

I have been trying on and off for a few months to connect Reach RS to M+ with 3DR radios. I even tried to connect them through Mission Planner. I connected Reach RS to mission Planner but could not get the M+ to work.
I also tried to connect the Emlid LoRa Radio to the M+. I powered the M+ on through the USB port. I then plugged the LoRa radio in S2 with the 7 pin cable it came with. The LoRa radio will not even turn on. No lights and the reach view app shows no connection to LoRa as well. When I plug in the 3DR radio into the S1 slot the lights come on. A solid green light and flickering red light, after it connects with the other antenna of course. Is there another way to figure out if the S2 port in bad or if the LoRa radio is the problem?

I find that it is best to plug both radios into a PC and test by sending data through one and receiving on the other. You may need adapters to to that (UART-RS232 board, USB-serial adapter, or FTDI USB cable, etc.)

Once you verify the radios work, then attach Reach to a PC, set to output position data. Monitor data coming into the PC. Do it again for the other Reach device.

Once you verify both Reach devices can output data, then plug one radio into a Reach that is outputting position data and plug the other radio into the PC. Monitor the data coming into the PC.

Once you verify that a Reach can send output data through the radio to the PC, then plug the last radio into a Reach that is listening for data.

After going through step-by-step, you will be successful in determining the problem.


Thanks bide, some of that I have tried, the stuff I haven’t I will try tmrw. As for the LoRa Radio, Can I be missing something. No lights= Not working, right?

When the LoRa module is given 5V, the green LED should be illuminated:

Thank you sir, I actually tried that last night. It must be my S2 port because the power works on the LoRa radio. I have no idea how that happened since I have never used that port. Guess I will have to find I way to solve this problem another way.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.